sayzlim

Fixing Your Reveal in Finder Not Working With This Workflow

7 posts in this topic

Just in case anyone need encounter problem with Reveal in Finder with Alfred, it’s not Alfred’s fault. You need to relaunch Finder and kill some process. I’ve included the workflow download link here with some bonus: http://d.pr/f/xrvs

 

I’ve explained it in my post:

 

 

If you’ve encountered a bug that stops you from revealing Alfred search result in Finder, then you’ll need this command. Usually it happened after you relaunch Finder without killing “appleeventsd” process. With this, you can relaunch Finder and kill the process in one stroke. Because we need sudo command, you’ll need to enter your user password in the workflows menu (see the Relauch Finder shell script).

 

Let me know if you find it useful.

Share this post


Link to post

Very nice bunch of utilities. If you add "Toggle hidden files" to the collection, it'd be just about complete! ;)

 

Just one thing - I'm not particularly keen on entering my password in plain text in a config menu. Any chance you could whip up a little Applescript (or something) to prompt the user for their password each time? (I might do this myself if I find some time.)

 

Cheers, and thanks for the workflow.

Share this post


Link to post

FYI, if anyone else is not keen on having their password stored in a workflow, just change the keyword to require an argument, and change the script to the following:

 

password="{query}" 

killall Finder && echo "$password" | sudo -S killall -KILL appleeventsd

echo "Finder has been relaunched"

Then you just type "relaunch yourpassword" each time instead. Voila! :)

sayzlim likes this

Share this post


Link to post
FYI, if anyone else is not keen on having their password stored in a workflow, just change the keyword to require an argument, and change the script to the following:

 

password="{query}" 

killall Finder && echo "$password" | sudo -S killall -KILL appleeventsd

echo "Finder has been relaunched"

Then you just type "relaunch yourpassword" each time instead. Voila! :)

 

 

Even better you can let applescript do the shell script with administrator privileges ...

 

osascript -e "do shell script \"killall Finder && sudo -A killall -KILL appleeventsd\" with administrator privileges"

 

Then you will get a popup asking for your password, this way your password will never be in the clear.

CarlosNZ likes this

Share this post


Link to post

I have problem with the echo returning an extra break line by using osascript. Any clues?

 

Hi

 

 

When echo'ing af string, echo always end the string with a 'return character' as standard.

But you can tell it not to that, by using the '-n" option.

 

Like this "/bin/echo -n 'Textstring'"

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now