Jump to content

taja

Member
  • Content Count

    12
  • Joined

  • Last visited

About taja

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. @taja Hi - sorry for taking a while. I replaced the script in my copy of 1.2.7 with the one you just provided and it works!
  2. @iandol Hi - just tested beall and betitle on 1.2.7 and it works *except* when I search for one term that should return a very large number of results (for reference, when I type it into search field in Bookends it returns nearly 3000 results). Neither beall nor betitle return any results when searching for it. I don't know if the problem relates to the sheer number of results. This might be a bit of an edge case, because beall works fine in all other cases, e.g.: 2018-07-12 09:46:21][trigger.hotkey] Processing output of 'input.scriptfilter' with arg '' [2018-07-12 09:46:23][input.scriptf
  3. @iandol I'm afraid I get another error with 1.2.6 when using beall. Here's what ocmes up: [2018-07-11 17:02:06][ERROR: input.scriptfilter] Code 1: /Users/Was/Library/Application Support/Alfred 3/Alfred.alfredpreferences/workflows/user.workflow.16824124-417E-42A2-BC67-A5CA41BCFCAD/findReferencesAll.rb:215:in `processAuthor': undefined method `chomp' for nil:NilClass (NoMethodError) from /Users/Was/Library/Application Support/Alfred 3/Alfred.alfredpreferences/workflows/user.workflow.16824124-417E-42A2-BC67-A5CA41BCFCAD/findReferencesAll.rb:198:in `parseAuthors' from /Users/Was/Libra
  4. @iandol no fault about it! And I'm very glad to know how easy it is to debug a workflow using Alfred. Thank you for fixing it so quickly!
  5. Sorry - I'm quite new to Alfred. Here's what the workflow debugger threw up. Apologies if this isn't the right thing to be providing here, but this is what comes up in the debugger (with 'interesting information' only selected) when I use (1) beall and (2) betitle. (1) Starting debug for 'Bookends Tools' [2018-07-10 11:04:07][ERROR: input.scriptfilter] Code 1: /Users/Was/Library/Application Support/Alfred 3/Alfred.alfredpreferences/workflows/user.workflow.C38A9670-F1D2-4A70-9F49-35850C922B4F/findReferencesAll.rb:245:in `<main>': uninitialized constant FindReferences (
  6. 1.2.5 doesn’t work for me for some reason: searches don't come up with any results. Odd because 1.2.4 (which I have reverted to) works fine. Any thoughts on what might be happening?
  7. Thanks again for this fantastic tool. A request: at the moment you can go to the selected reference in Bookends from the results list, and then open its attachment using the relevant keyboard shortcut in Bookends. But would it be possible to open the reference attachment directly from the search results using a modifer key?
  8. @iandol Fantastic, works great, and thanks for the pointer about malformed dates, I've sorted that out now.
  9. I've added my Powerpack email. @iandol I have around 7000 references. I can only isolate one author, it turns out, for which the author search simply doesn’t work (i.e. returns no results). 'Arendt, Hannah', with no accents or diacritics. But I have a lot of references attached to her (she's the subject of a book I'm finishing): 290. I made a small test database with all those references, and with one reference from one other author, and the same problem occurs: here is the test DB: https://www.dropbox.com/s/b64xxbe5f8g2oel/Test.bdb?dl=0. When I remove say 200 of those references, the search
  10. iandol: these are fantastic, however using v.1.1.0 (the latest I think), when doing a very few certain author and title searches that should return a lot of results (and do in Bookends live search) i get nothing at all. Any thoughts on what might be going wrong?
×
×
  • Create New...