Jump to content

Thomas Dunne

Member
  • Content Count

    2
  • Joined

  • Last visited

  1. Really interesting and useful. But I've noticed some cooking and everyday small life US-American units aren't supported: For example, teaspoons, tablespoons, cups... and fractions: 1/8 inch, 1/16 tablespoon It'd be nice to have those.
  2. I think my problem is the same. I have deleted and imported the workflow several times already choosing not to import previous settings. I have also checked that the paths are ~/Downloads. But I still cannot manage to get it to work. I think I follow the instructions correctly. 1. I open a youtube video. 2. Copy the URL to my clipboard. (for example: https://youtu.be/tRcPA7Fzebw but I've tried many other links from YouTube and other websites supported by youtube-dl) 3. Type “dv” into Alfred. 4. Press enter / or click on the suggested search result (which is Downvid's “Download video / Downloads the video to ~/Downloads) But I don't get a notification. I have also tried “dvp” but it says that there are no downloads in process. I haven't tried to install youtube-dl or anything else as it is my understanding the workflow takes care of everything it needs itself. The debug log: [03:45:46.503] DownVid[Script Filter] Queuing argument '' [03:45:46.877] DownVid[Script Filter] Script with argument '' finished [03:45:46.881] DownVid[Script Filter] {"items":[{"uid":"dv","title":"Download Video","subtitle":"Downloads the video to ~/Downloads","arg":"/Users/elv/Downloads video watchlist_false playlist_false","mods":{"cmd":{"subtitle":"Download full playlist","arg":"/Users/elv/Downloads video watchlist_false playlist_true"}}},{"uid":"da","title":"Download Audio","subtitle":"Downloads the audio to ~/Downloads","arg":"/Users/elv/Downloads audio watchlist_false playlist_false","mods":{"cmd":{"subtitle":"Download full playlist","arg":"/Users/elv/Downloads audio watchlist_false playlist_true"}}}]} [03:45:48.143] DownVid[Script Filter] Processing complete [03:45:48.146] DownVid[Script Filter] Passing output '/Users/elv/Downloads video watchlist_false playlist_false' to Run Script [03:45:48.453] ERROR: DownVid[Run Script] Could not download resource. ./downvid: line 8: sed: No such file or directory ./downvid: line 9: sed: No such file or directory ./downvid: line 13: awk: No such file or directory ./downvid: line 14: awk: No such file or directory ./downvid: line 15: awk: No such file or directory ./downvid: line 16: awk: No such file or directory ./downvid: line 46: youtube-dl: No such file or directory ./downvid: line 50: basename: No such file or directory ./Notificator.app/Contents/Resources/Scripts/notificator: line 8: basename: No such file or directory ./Notificator.app/Contents/Resources/Scripts/notificator: line 9: dirname: No such file or directory ./Notificator.app/Contents/Resources/Scripts/notificator: line 9: dirname: No such file or directory ./Notificator.app/Contents/Resources/Scripts/notificator: line 9: dirname: No such file or directory ./Notificator.app/Contents/Resources/Scripts/notificator: line 10: dirname: No such file or directory ./Notificator.app/Contents/Resources/Scripts/notificator: line 10: dirname: No such file or directory ./Notificator.app/Contents/Resources/Scripts/notificator: line 10: dirname: No such file or directory ./Notificator.app/Contents/Resources/Scripts/notificator: line 66: touch: No such file or directory ./Notificator.app/Contents/Resources/Scripts/notificator: line 67: osascript: No such file or directory ./Notificator.app/Contents/Resources/Scripts/notificator: line 68: /MacOS/applet: No such file or directory [03:45:48.465] DownVid[Run Script] Processing complete [03:45:48.467] DownVid[Run Script] Passing output '' to Run Script I also ran the commands you suggested on Terminal: ELV:~ elv$ which sed /usr/bin/sed ELV:~ elv$ which awk /usr/bin/awk ELV:~ elv$ which youtube-dl ELV:~ elv$ I am running on a fresh install of Mojave (10.14.6). I don't think I've done anything to alter the system significantly Alfred version is 4.0.1 Any idea what's wrong? Nevermind. My firewall was blocking internet access to cURL. The workflow is working now.
×
×
  • Create New...