Jump to content

Kennon Bickhart

Member
  • Content Count

    19
  • Joined

  • Last visited

Everything posted by Kennon Bickhart

  1. Thanks for the great workflow Vítor. I sent you a pull request with Webkit and Chrome Canary support, as I use those as my primary browsers.
  2. A thought... Is there a URL scheme, or something, that you could tie into so if you hit ENTER it goes to the web plugin, but if you hit CMD+ENTER it goes to the app with the search pre-filled and you can copy there by hitting CMD+OPT+C? It's more work than what jorbsd proposed, but keeps you secure.
  3. I had 19 custom searches and they all came across perfectly. Wonderful idea!
  4. Thanks. This is great. I've been wanting to make something like this for a little while now.
  5. Ditto. I just ran into this issue this past week as I've been waiting until I could get decent Dropbox and Droplr workflows in place before switching.
  6. Ah, that makes sense. Hopefully it's just a bug, but your workflow is a good workaround.
  7. Just adding that I also have this issue. I hadn't worked on anything in the simulator yet since installing v2, and just noticed this issue today. I have both paths (the default: /Applications/Xcode.app/Contents/Applications & /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer....) and the iPhone/iOS Simulator isn't showing up. Other apps do show though, like Instruments and FileMerge.
  8. No problem. It was just something quick. I'll see if I can find some more information about doing what you want too.
  9. Very basic. Usage: -- srv smb://ServerName -- srv afp://ServerName http://d.pr/f/ITMw
  10. It looks like it's an encoding issue on my end. I have a few bookmarks with odd characters (imported by Safari from when I joined Pinboard), and it's choking on those (dashes and >> primarily). Once I got rid of the problematic characters everything started functioning fine. EDIT: Did some investigating and it's the htmlentities() call that's the issue. It's causing certain characters to just go wrong. However, removing that causes the above error from "dansherman" to come back. I know this isn't the right way, but I added "error_reporting(0);" and removed the htmlentities() around title and description, and that seems to be ok. It has a few character issues, but I'm getting all my bookmarks returned.
  11. This is actually how I thought workflows would work when I first opened v2. Here's hoping that this is on the roadmap, as I think it'd be a super addition.
  12. It appears like it should accept tags as well as titles, descriptions, etc... Is that true? Currently tags don't seem to display any results.
  13. Hey, I wanted to create a workflow that would allow me to see all of my project files in a single directory. Similar to how CMD+CTRL+P works in Sublime Text 2. I also wanted to be able to search through those items. So I borrowed the core of the "Google Auto Complete" workflow from David Ferguson (A Few Alfred 2 Workflows to Get You Started), and repurposed it for my needs. I'm not great at PHP, so I'm betting that there might be a better way. I also like the idea of bucketing apps into workflows, so I also included the work done by phillistein (http://www.alfredforum.com/index.php?/topic/39-open-in-sublime-and-search-sublime-projects/). There's one variable you'll have to modify for your system. That's the dir that it uses to display all .sublime-project files. Inside, you'll see a "proj" script filter. Open that and change the $dir variable to a local path on your system. v1.0: http://d.pr/f/qvZM *NOTE: I'd like to add the ability to recursively search through the filesystem, so you could just start at your home directory.
  14. Yea, I don't think this is editable currently. I bet it's on the radar though. This is one of the reasons I'm using a light theme. Oh, and I like this theme. Great job!
×
×
  • Create New...