Jump to content

xilopaint

Member
  • Content Count

    547
  • Joined

  • Last visited

  • Days Won

    21

Everything posted by xilopaint

  1. The latest version of the workflow is working for me on Catalina.
  2. Hey guys, I just created a workflow for keeping track of COVID-19 statistics. Stay safe! https://github.com/xilopaint/alfred-covid-19-radar
  3. If I keep `from workflow import Workflow` in background.py I get this: 21:25:53 workflow.py:2061 DEBUG ---------- Alfred PDF Tools (2.16.0) ---------- 21:25:53 workflow.py:1468 DEBUG reading settings from /Users/****/Library/Application Support/Alfred/Workflow Data/com.xilopaint.alfredapp.pdftools/settings.json 21:25:53 workflow.py:2338 INFO checking for update ... 21:25:53 background.py:233 DEBUG [__workflow_update_check] command cached: /Users/****/Library/Caches/com.runningwithcrayons.Alfred/Workflow Data/com.xilopaint.alfredapp.pdftools/__workflow_update_check.argcache 21:
  4. Hey @deanishe, after fixing a lot of issues in the attempt of adapting the library for Python 3 I came across this: 10:01:18 workflow.py:2061 DEBUG ---------- Alfred PDF Tools (2.16.0) ---------- 10:01:18 workflow.py:1468 DEBUG reading settings from /Users/xxxx/Library/Application Support/Alfred/Workflow Data/com.xilopaint.alfredapp.pdftools/settings.json 10:01:18 workflow.py:2338 INFO checking for update ... 10:01:18 background.py:233 DEBUG [__workflow_update_check] command cached: /Users/xxxx/Library/Caches/com.runningwithcrayons.Alfred/Workflow Data/com.xilopaint.alf
  5. Nah, I just realised it's an import issue. Python 3 doesn't support implicit relative imports.
  6. Well, at the moment I'm getting `ModuleNotFoundError: No module named 'util'`. I should be missing something very basic. I have no clue why I'm getting this error.
  7. @deanishe I need something like `Wofklow3.cache_data()` and `Workflow3.cached_data()` in a Python 3 workflow. Would it be easy to adapt alfred-workflow to work with Python 3 for those methods or you recommend me to simply write and read the cache files using Python 3?
  8. Optimize is not a keyword, it's a file action. In the following link you can see how to perform a file action: https://www.alfredapp.com/blog/tips-and-tricks/file-actions-from-alfred-or-finder/
  9. Is v2 already in the road map with Python 3 support? 😁
  10. Any chance to get the method added to the library?
  11. Is there anything in Alfred-Workflow like the `Requests.iter_lines()` method?
  12. This workflow is working normally for me.
  13. Did you rerun the tinypng_config keyword and entered your API key after making this adjustment? If not you're not using your own API key.
  14. @Roman52 I see you're using the keyword. Do you have the same issue by using the file action instead of the keyword?
  15. @Roman52 do you still have the issue if you try to shrink one file at a time.
  16. Yes. I guess Catalina is frowned upon because of the hard Beta program which was surrounded by a lot of criticism. Yet I haven't been facing issues since the release of the first stable version, it's been really pretty stable for me.
  17. I should add that I followed this procedure with no success.
  18. Hey Vitor, I'm getting this: [03:47:25.544] MarkdownTransform[Hotkey] Processing complete [03:47:25.547] MarkdownTransform[Hotkey] Passing output 'ksfklsdjfklsdjfl[ksd]jfl' to Run Script [03:47:32.491] STDERR: MarkdownTransform[Run Script] /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require': cannot load such file -- redcarpet (LoadError) from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require' from /Users/***/Library/Application Suppor
  19. @Roman52 please, try running the workflow again and paste here the output of the Alfred debbuger.
  20. You have to make the same change in the Run Script object connected to the tiny_png_config keyword on Alfred Editor.
  21. I know my currency code but if I enter it via `Set base currency` and `Set currency locale` I don't get my currency properly formatted. It seems your workflow is not accepting capital letters, so "Y" is being converted to "y" which gives different results for a date format.
  22. I'm struggling to configure my currency and date formats. Is there a list anywhere that could help me with that?
×
×
  • Create New...