Jump to content

Ripcordian

Member
  • Content Count

    13
  • Joined

  • Last visited

  1. UPDATE: Added a row to automatically switch back to the application that was active when you envoked the script (wich puts foucs on the desktop). This means no windows will disapear, but instead there will be a slight flicker. on alfred_script(q) activate application "Finder" tell application "System events" keystroke "1" using {option down, command down} keystroke tab using {command down} end tell end alfred_script
  2. Hi! This applescript will get it done. This will work for any menu shortcut available in finder. Just add a hotkey or a keyword trigger in Alfred. I prefer keywords as i think they are easier to remmeber then hotkey. I use a similiar script to activate the menu in Sanedesk to switch virtual desk, but the icons always get scrambled, so i just type "clean" to activate the script below. on alfred_script(q) activate application "Finder" tell application "System events" keystroke "1" using {option down, command down} end tell end alfred_script
  3. And a little feature request as well: Often i just wanna search for an artist i like and just start playing that artist (with shuffle) is it possible to ad that option? As it is now i just get the option to "browse" the artist. Thanks! edit: the same goes for albums. Perhaps Enter could be "browse" and shift+Enter could be "shuffle play"?
  4. UPDATE: It all seems to work perfect today, might have been just a hick-up of some sorts. Thanks anyway! -------------------------------------------------- Hey Citelao, thanks for this awesome script! Can't tell you how much i missed something that could match the directness of the "jump"-function in Winamp about two decades ago Unfortunatley it stopped working for me with the latest spotify update (0.9.14.13.gba5645ad). I'm on the latest Spotifious 0.9.4. When I enter my keyword Spoti and a song, "Spoti Cult logic"i get a message that the spotify api could'nt be reached. Below is at transcript of the log. Hope it's an easy fix. Oh and check out the great song i mentioned, by Mike Snow aswell Thanks! # Error Log # ## Error Info ## Could not access Spotify API. Try searching again Line 26, /Users/rickardortegren/Library/Application Support/Alfred 2/Alfred.alfredpreferences/workflows/user.workflow.FB4295A1-5196-4097-A138-538A52F297ED/src/citelao/OhAlfred/HTTP/Fetcher.php ## Symbols ## Array ( [message] => Could not access Spotify API. Try searching again [vars] => [0] => Array ( [file] => /Users/rickardortegren/Library/Application Support/Alfred 2/Alfred.alfredpreferences/workflows/user.workflow.FB4295A1-5196-4097-A138-538A52F297ED/src/citelao/OhAlfred/HTTP/JsonFetcher.php [line] => 15 [function] => run [class] => OhAlfred\HTTP\Fetcher [type] => -> [args] => Array ( ) ) [1] => Array ( [file] => /Users/rickardortegren/Library/Application Support/Alfred 2/Alfred.alfredpreferences/workflows/user.workflow.FB4295A1-5196-4097-A138-538A52F297ED/src/citelao/Spotifious/Menus/Search.php [line] => 24 [function] => run [class] => OhAlfred\HTTP\JsonFetcher [type] => -> [args] => Array ( ) ) [2] => Array ( [file] => /Users/rickardortegren/Library/Application Support/Alfred 2/Alfred.alfredpreferences/workflows/user.workflow.FB4295A1-5196-4097-A138-538A52F297ED/src/citelao/Spotifious/Spotifious.php [line] => 60 [function] => __construct [class] => Spotifious\Menus\Search [type] => -> [args] => Array ( [0] => cult ) ) [3] => Array ( [file] => /Users/rickardortegren/Library/Application Support/Alfred 2/Alfred.alfredpreferences/workflows/user.workflow.FB4295A1-5196-4097-A138-538A52F297ED/main.php [line] => 23 [function] => run [class] => Spotifious\Spotifious [type] => -> [args] => Array ( [0] => cult ) ) )
  5. I guess now we all just have to remember to update the scripts when Mailbox comes out of beta, so it no longer ref. "Mailbox (beta)" but simply "Mailbox".
  6. Brilliant TWHarr, that did it for me aswell, thanks!
  7. Check out the workflow "iM" by Nolan Chan, it's more direct imo.
  8. I might be getting you wrong, but I think what you mean is simply a matter of using the arrow down/up? cheers
  9. This is a workflow to activate the dock (even if hidden) and navigate it with arrow keys and enter-key. I know i know, Alfred is all about making the dock redundant. But I find myself reaching for the dock juuust often enough that it'd be nice to access it without using a mouse or trackpad. The workflow uses a keyword "dock", or a hotkey "ctrl+D", of course this can be changed to whatever suits you. The workflow activates a script that basically mimics the keystroke: fn+ctrl+F3. For some reason it only worked after i removed the fn-key from the script, don't know what that's about. I'm not at all a coder, so feel free to modify and re-post! Can't figure out how to upload file (...) so here's a link to it https://copy.com/StKxMpHB1Fw4byX2 Thanks to Alfred for being Alfred, Love Rickard
  10. edit: opening/activating Mailbox in Alfred by just typing the app name works fine, even if minimized
  11. Hey Justin, sorry I haven't got back to you, thought I'd get a notification from the forum of some sort if you'd replied. Guess it's in the settings. Anyways: I took a closer look, and it turns out all of the scripts works fine if MB is either active or hidden. The problem occur if it's minimized, I'm on a Macbook Pro mid 2014, specs below. Running Mavericks 10.9.4 and latest build of MB. Hope you can figure it out, thanks a lot / Rickard Model Name: MacBook Pro Model Identifier: MacBookPro11,3 Processor Name: Intel Core i7 Processor Speed: 2,5 GHz Number of Processors: 1 Total Number of Cores: 4 L2 Cache (per Core): 256 KB L3 Cache: 6 MB Memory: 16 GB Boot ROM Version: MBP112.0138.B07 SMC Version (system): 2.19f7
  12. Hey Justin, Thanks for the workflow, iv'e been missing it since the mailbox app came out I cant get it to work properly though; it works perfectly fine when MB already is on my desk, it doesn't have to be active either. But when minimized i just get a "thump"-sound and nothing happens. I looked at the script (not knowing much about theese things) and it seems like the "tell application x to activate" might need to be preceeded by a "tell application x to maximize" or something first? If you got the time, i'd sure appreciate if you took a look at it. Thanks, Rickard
×
×
  • Create New...