Jump to content

netnothing

Member
  • Content Count

    8
  • Joined

  • Last visited

  1. Thanks! This worked out perfectly.....and much better than my hack ;-) Only thing I changed was I added "activate" within the tell so that KeepassX's window would be brought to the front. -Kevin
  2. Thanks everyone. Ended up creating aliases to the files in Dropbox on both machines. The aliases are in the same folder I have, within my home folder, on both machines.....so the workflow will work across both machines. -Kevin
  3. I have Alfred installed on my 2 machines. I'm syncing prefs....so naturally workflows are synced. I have a workflow that uses Launch apps/files to quickly launch KeePassX, opening a certain database file. Now, the DB file it opens is stored in my Dropbox folder. However, recently I changed the location of my Dropbox folder on my main machine. I of course had to update my Workflow to point to the new file path, however, this is now breaking this workflow on my other machine since the Dropbox folder paths don't match. Anyway to fix this? I tried manually editing the workflow path, but it doesn't allow that. Was going to put a symlink in my main machine homefolder to Dropbox to set the path back.....but the workflow only allows drag/drop of files. -Kevin
  4. Would love to see a play/scrubber bar in the Alfred Mini player so I can see where in a song/podcast I am and be able to scrub from there (if possible). -Kevin
  5. Vero, Thanks for looking into this. I have since removed the widget and have not had the issue since. Glad you can report it. Going to add a feature request to the other forum to suggest a status play bar in the mini player. -Kevin
  6. Vero, So I only have the following widgets in Notifications center: iTunes World Clock Weather All of these are the official Apple widgets. I've tracked it down to the iTunes widget. With that widget active, I get the errors and my hotkeys don't work. If I remove that widget, everything works and no errors. This seems like it was introduced in 10.10.3 as I know the widget was working prior. Any thoughts? Is this something Apple needs to fix? -Kevin
  7. I'm not exactly sure whether this is an Alfred or Yosemite issue. I'm running: Alfred 2.7.1 (387) Yosemite 10.10.3 I have the iTunes Widget on in Notification Center. I have always had 2 workflows setup in Alfred that are mapped to F18 and F19 that control iTunes Volume Down and Up. I notice lately that if iTunes is playing something, and I first open Yosemite Notification center and close it, that I get the following errors in console and the volume key workflows don't work: THIS FIRST BIT IS FROM OPENING NOTIFICATION CENTER: May 18 09:55:22 pkd[316]: enabling pid=329 for plug-in com.apple.ncplugin.WorldClock(1.0) F13DFFD6-D083-4777-9EFD-7DE7ED4BAC75 /System/Library/Frameworks/NotificationCenter.framework/PlugIns/com.apple.ncplugin.WorldClock.appex May 18 09:55:22 pkd[316]: enabling pid=329 for plug-in com.apple.ncplugin.weather(1.0) 574068F7-8DDC-4086-8538-3FA82541873E /System/Library/Frameworks/NotificationCenter.framework/PlugIns/com.apple.ncplugin.weather.appex May 18 09:55:22 pkd[316]: enabling pid=329 for plug-in com.apple.iTunes.today.TodayExtension(1.0) 4E712565-5471-43CF-A8B2-0B8BD11A4F4E /Applications/iTunes.app/Contents/PlugIns/TodayExtension.appex May 18 09:55:23 locationd[293]: Couldn't find a requirement string for masquerading client /System/Library/Frameworks/NotificationCenter.framework/PlugIns/com.apple.ncplugin.weather.appex May 18 09:55:23 locationd[293]: could not get apple languages array, assuming english May 18 09:55:23 locationd[293]: Location icon should now be in state 'Active' THESE ARE THE ACTUAL ERRORS: May 18 09:55:28 Alfred 2[370]: [ERROR] AppleScript Error: { NSAppleScriptErrorAppName = "TodayExtension.appex"; NSAppleScriptErrorBriefMessage = "Can\U2019t get \U00abclass pVol\U00bb."; NSAppleScriptErrorMessage = "TodayExtension.appex got an error: Can\U2019t get \U00abclass pVol\U00bb."; NSAppleScriptErrorNumber = "-1728"; NSAppleScriptErrorRange = "NSRange: {0, 0}"; } May 18 09:55:28 Alfred 2[370]: [ERROR] AppleScript Error: { NSAppleScriptErrorAppName = "TodayExtension.appex"; NSAppleScriptErrorBriefMessage = "Can\U2019t set \U00abclass pVol\U00bb to 0."; NSAppleScriptErrorMessage = "TodayExtension.appex got an error: Can\U2019t set \U00abclass pVol\U00bb to 0."; NSAppleScriptErrorNumber = "-10006"; NSAppleScriptErrorRange = "NSRange: {0, 0}"; } I will get these with each button press. Now, once this happens, the actual volume won't change. However, after 30 seconds or so, it will start to work again. I do notice this error occasionally, even without opening Notification Center: May 18 10:05:06 Alfred 2[370]: [ERROR] AppleScript Error: { NSAppleScriptErrorBriefMessage = "An error of type -10827 has occurred."; NSAppleScriptErrorMessage = "An error of type -10827 has occurred."; NSAppleScriptErrorNumber = "-10827"; NSAppleScriptErrorRange = "NSRange: {0, 0}"; } This error seems to happen on the very first button press to change volume, but after that the volume does change. -Kevin
×
×
  • Create New...