Jump to content

Search the Community

Showing results for tags 'alfred-workflow'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Alfred 3
  • Make the Most of Alfred
    • Discussion & Help
    • Bug Reports
    • Alfred Feature Suggestions
    • Themes
  • Alfred Workflows
    • Share your Workflows
    • Workflow Help & Questions
  • Alfred v2 Themes
  • Alfred Remote for iOS
    • Alfred Remote Discussion & Help
    • Remote Connection Troubleshooting

Categories

  • Articles
    • Forum Integration
    • Frontpage
  • Pages
  • Miscellaneous
    • Databases
    • Templates
    • Media

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Twitter


Website URL


Jabber


Location


Interests

Found 4 results

  1. Alfred-Workflow installs with pip for python3, but on usage it calls modules that don't exist in python3. Is there a way around this, or do scripts need to be run with python 2? Will this change in the future? Very new to this, trying to setup my own simple workflow.
  2. Hi, I'm tying to get my first workflow up and running. However I get an exception when using alfred-workflow. I'm trying to save a keychain using wf.save_password('ha_password', args.apikey) The exception that i get: [2018-03-21 14:19:55][ERROR: action.script] . 14:19:55 workflow.py:2057 DEBUG ---------- Home Assistant ---------- 14:19:55 workflow.py:2074 ERROR Unknown Keychain error : security: SecKeychainItemCreateFromContent (<default>): The user name or passphrase you entered is not correct. Traceback (most recent call last): File "/Users/andreas/Library/Application Support/Alfred 3/Alfred.alfredpreferences/workflows/user.workflow.A66C80D9-3423-441F-BEFA-CD9F0317B9A2/workflow/workflow.py", line 2067, in run func(self) File "home_assistant.py", line 50, in main wf.save_password('ha_password', args.apikey) File "/Users/andreas/Library/Application Support/Alfred 3/Alfred.alfredpreferences/workflows/user.workflow.A66C80D9-3423-441F-BEFA-CD9F0317B9A2/workflow/workflow.py", line 2407, in save_password '-w', password) File "/Users/andreas/Library/Application Support/Alfred 3/Alfred.alfredpreferences/workflows/user.workflow.A66C80D9-3423-441F-BEFA-CD9F0317B9A2/workflow/workflow.py", line 2817, in _call_security raise err KeychainError: Unknown Keychain error : security: SecKeychainItemCreateFromContent (<default>): The user name or passphrase you entered is not correct. I'm on High Sierra, 10.13.3. Alfred is freashly installled and alfred-workflow is fetched today. Someone any ideas? Thanks! //Andreas
  3. There is a bug in my (unofficial) Alfred-Workflow library that causes very many workflows using it to hang quite dramatically on Sierra. If you are affected (i.e. you see Alfred's CPU usage spike to 100%), Activity Monitor will show two Python processes like this (choose View > All Processes, Hierarchically), with the bottom one at ~99% CPU (this screenshot is actually of a non-misbehaving workflow): Download and run this workflow, which will update any old versions of Alfred-Workflow in your installed workflows. That should get your workflows working again until the workflow developers can push official fixes.
  4. Hi folks! Long time lurker, first time poster, etc., etc. I'm in the midst of writing a new workflow using Deanishe's wonderful alfred-workflow modules, and I'm hitting a wall in regards to using setvar(var, value). I think that I'm expecting it to work differently than it's working, and that my understanding is flawed and I need some help. In the my workflow, keyword "su newticket" and run script "new_ticket.py" is the action I'm concerned with. The upper workflow can be ignored and isn't implemented yet. I'm just trying to call a python script, set a variable, and return it as a {var:<name>} variable. If I use a "copy to clipboard" node, I can see the variable I want embedded in JSON inside {query}, but if I try to access {var:message_out}, there's nothing. This is where I'm falling down Workflow here: https://www.dropbox.com/s/8kjpu6jk4ze4moc/StreetUtils.zip?dl=0 Relevant info: Alfred 3.3.2 [818] macOS 10.12.4 (Darwin Kernel Version 16.5.0: Fri Mar 3 16:52:33 PST 2017; root:xnu-3789.51.2~3/RELEASE_X86_64 x86_64) Alfred-Workflow 1.25.2 Any non-system language you're using (e.g. nodejs): none Any non-system programs you're using (e.g. ffmpeg or youtube-dl) if they aren't bundled in your workflow: none Any changes you've made to your macOS environment (e.g. via launchctl setenv) or the language you're using (e.g. via Python's usercustomize.py or sitecustomize.py files): none I appreciate any advice or guidance! Thanks in advance and all that -tony.
×
×
  • Create New...