Jump to content

Search the Community

Showing results for tags 'japanese'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Alfred 3
  • Make the Most of Alfred
    • Discussion & Help
    • Bug Reports
    • Alfred Feature Suggestions
    • Themes
  • Alfred Workflows
    • Share your Workflows
    • Workflow Help & Questions
    • Advanced Tips & Tricks
  • Alfred v2 Themes
  • Alfred Remote for iOS
    • Alfred Remote Discussion & Help
    • Remote Connection Troubleshooting

Categories

  • Articles
    • Forum Integration
    • Frontpage
  • Pages
  • Miscellaneous
    • Databases
    • Templates
    • Media

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Twitter


Website URL


Jabber


Location


Interests

Found 2 results

  1. Hello! I'm attempting to set up a workflow that includes passing a unicode character with a diacritic through a shell script. However, the "Run Script" node in the workflow seems to be converting its input to another representation of the characters which cause issues. In particular, the character being passed into the bash script is when the issue seems to be occurring. More specifically, I'm using a workflow that takes the currently selected Japanese text, and does something with it. In this example, the bash script just re-echos the input, and then the text is searched on Jisho.org (a Japanese-English dictionary site). The character `が` demonstrates the issue. The version which is passed through the bash script changes to another representation of `が` which on Jisho.org is searched as a separated `か` and the ` ゙` (dakuten diacritic). I've attached a simplified workflow below which presents my issue. It includes the action I would like to achieve, as well as a couple other example cases showing that the character seems to be changed on input into the bash script (e.g., setting the character within the bash script works as desired, but setting it within one bash script and passing it to another does not). I'm assuming this question has been answered before, but the answers I found with my various search term attempts did not seem to turn up the answer I was looking for. I apologize in advance for the likely repeat. Any suggestions and/or explanations would be appreciated. Thank you for your time! Google Drive link to workflow: https://drive.google.com/file/d/1YXoz4KWt_4XbTJtrdM4MKJlmSe9rompl/view?usp=sharing Alfred 4.6.3 macOS 12.2.1
  2. Easily and quickly translate from Japanese to English or vice versa using this workflow! I thought this would be a helpful workflow for those of you out there who are learning/interested in learning Japanese! It makes looking up and double checking words/sentence much faster. This work flow offers three tools: Vocabulary definitions straight from Jisho.org Japanese Verb conjugations Sentence translation using google translate To install, visit my packal or GitHub. Demo: Note: conjugation takes a little bit longer to generate compared to the vocabulary as vocabulary utilizes Jisho.org's API to gather definitions, while the conjugations are gotten through Beautiful Soup 4.
×
×
  • Create New...