Jump to content

Search the Community

Showing results for tags 'open -a'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Alfred 3
  • Make the Most of Alfred
    • Discussion & Help
    • Bug Reports
    • Alfred Feature Suggestions
    • Themes
  • Alfred Workflows
    • Share your Workflows
    • Workflow Help & Questions
  • Alfred v2 Themes
  • Alfred Remote for iOS
    • Alfred Remote Discussion & Help
    • Remote Connection Troubleshooting

Categories

  • Articles
    • Forum Integration
    • Frontpage
  • Pages
  • Miscellaneous
    • Databases
    • Templates
    • Media

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Twitter


Website URL


Jabber


Location


Interests

Found 1 result

  1. I have modified the Searchio! Alfred workflow of Dean (http://www.packal.org/workflow/searchio) to be able to directly play audio (from youtube for example) using mpv. For this I took inspiration from the ShortFilms workflow of Vitor (http://www.packal.org/workflow/shortfilms). To do this, I previously used: open -a "${audio_player}" "${1}" --args --vid=no This worked perfectly until I upgraded (using brew (not brew cask)) to mpv 0.25.0 Since the upgrade, mpv doesn't recognise the args that are passed to it by open through the use of --args. A simple test for this is [in a terminal/command line window; note: this requires mpv and youtube-dl to be installed]: open -a mpv "youtube_video_link_here" --args --vid=no I have read the documentation of open and mpv and I am not sure why the behaviour changed. Anyone can help with this? The arguments passing issue using "open -a App_Name File_Name --args arg1" might be more widespread than just for this use case. Is there anything I am missing in the use of the command open? P.S.: 1) I have also filed a bug report with mpv (https://github.com/mpv-player/mpv/issues/4354) but I fear that this issue is more linked to the way "open" interacts with other commands (this worked with previous mpv versions though, i.e. mpv<0.25) 2) The modifications I have made allow to call for youtube video search in Searchio! using the alfred keyword "yt" and then: Choosing an item on the Alfred displayed list while using CMD launches the playback of the corresponding youtube video in mpv Choosing an item on the Alfred displayed list while using ALT launches the playback of the corresponding youtube audio in mpv
×
×
  • Create New...