Jump to content

Search the Community

Showing results for tags 'preferences'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Alfred 3
  • Make the Most of Alfred
    • Discussion & Help
    • Bug Reports
    • Alfred Feature Suggestions
    • Themes
  • Alfred Workflows
    • Share your Workflows
    • Workflow Help & Questions
  • Alfred v2 Themes
  • Alfred Remote for iOS
    • Alfred Remote Discussion & Help
    • Remote Connection Troubleshooting

Categories

  • Articles
    • Forum Integration
    • Frontpage
  • Pages
  • Miscellaneous
    • Databases
    • Templates
    • Media

Categories

  • New Features
  • Other

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Twitter


Website URL


Jabber


Location


Interests

Found 33 results

  1. I accidentally wiped out all of my preferences and settings. I did a restore from Time Machine but somehow, the settings and preferences were still all gone from within Alfred. I still have the preferences file but I can't get it to load into Alfred. I have tried opening the file with Alfred and that didn't work. I have entered it into the search bar and hit Enter and that didn't work. I need help here to load my preferences back into Alfred. ? I am surprised that this issue has not already been addressed. It seems to me that with all of the creative brain power existing in the Alfred community, that there is no workflow with a script to re-install preferences into Alfred.
  2. Good Day! Maybe this issue has been already raised here, but I still can't get, why I have no ability to change my web search engines. Alfred offers us only choosing the country, we live in, and it will adjust search engines by itself. But his choice doesn't satisfy me. Alfred still uses Google, Amazon and Wikipedia. I use NOTHING of these. I prefer Yandex services, that are very popular in Russia. So, it would be extremely convenient, if I had an ability (working the same as Alfred's general "Web Search" feature) to set my own web search engines. Maybe, I want five or only two prime resources. Maybe I need specific professional ones like stackoverflow.com or kinopoisk.ru. Why don't you have implemented this at the beginning of Alfred? Or I don't know something? Explain, please. Thanks in advance!
  3. In my Alfred Web Search preferences, I have disabled Google and Amazon, but I must be missing a checkbox somewhere because Alfred insists on putting Google and Amazon in the search results for any term that I type (see screenshots). How do I definitively disable Google and Amazon search?
  4. Hey! I am using the Dropbox auto-sync feature. How can I be sure that every time I change a setting it is saved? Both `Created` and `Modified` fields are set to the date I installed Alfred and the `Last Opened` is set to a couple of months ago where I probably double clicked the file. Is that normal? Thanks
  5. Hi, this is the second time this has happened and I am getting really frustrated with it. Yesterday while using Alfred, everything was working fine, until I went to add a snippet and noticed none of my existing snippets were loading for some reason. But my snippet auto-expansion was still working ok. So I figured there had to be some 'interference', or one of the other 10 things used as an excuse when the software doesn't work properly. So I rebooted to reset everything. Except now not only do the preferences not show up, they are now not even working at all. I tried loading my Alfred preferences file manually from my iCloud, but I noticed it was now zero bytes. I have my preferences synced to iCloud, (which was probably my first mistake after reading up here, but that is USELESS INFORMATION AFTER THE FACT), but either way this should not have happened. Totally losing my entire collection of snips, preferences, workflows and everything else that has been built up over months time is just unacceptable no matter what. If Alfred knows it is so unreliable, or it knows that iCloud is that unreliable, don't allow people to store things there, or keep an extra backup of the preferences stored somewhere. No I don't keep time machine backups, especially of random application config files of a few hundred kb, give me a break. So these preferences are pretty much gone again right?
  6. In Alfred 2, a small gear appeared in the top right corner of the pop up window that would open Alfred Preferences. The gear is gone in Alfred 3. I’ve never heard of (or used) Command + to open an app's preferences, but following those directions on another post here, I tried it. Failed again. How do I access Alfred Preferences in version 3?
  7. I think I've found a typo in Alfred Preferences > Features > File Search > Advanced I believe the proper escaped path should be 'Users/preppeller/Desktop/Andrew\'s Folder!/', i.e. the apostrophe isn't escaped and/or there's an erroneous double quote in text.
  8. I want to create a basic workflow that opens a few web pages and Alfred preferences using a keyword. I know this is possible as I created a workflow that only opens Alfred preferences in the past. But I can't make it this time. I think maybe I am trying to open the wrong file. Should I open the Alfred preferences file in my Dropbox file (I sync my preferences with Dropbox) or the one in my ~/Application Support/Alfred folder? Or any other file? Thank you.
  9. Sorry if this is a naive question. New user. I'd like to create a workflow that opens the OS X Sound control panel and then selects a particular sound output. I'm constantly switching between headphones, display, and USB output, so I'd like to automate that. Here's what I've got so far in the linked screenshot. It opens System Preferences no problem. From there, how can I get Alfred to open the Sound control panel, then output, then select one or another of the output options? In case it helps, I've attached an image of the Sound control panel.
  10. So excited - just powered up Alfred 3. But, I don't see the gear icon in the search bar to be able to access preferences. Thank you!
  11. A UI issue for you... iMac Retina 5k 27-inch Late 2015 OS X El Capitan 10.11.3 Alfred 2.8.2 (432) Reproducible: Yes Aways: Yes Tried on other machines: No Steps to reproduce: Open Alfred preferences Click the Features tab Click the Terminal / Shell section Change the Application dropdown to be Custom Close preferences Open Alfred preferences Click the Features tab Click the Terminal / Shell section Change the Application dropdown to be Terminal Results is that you see parts of the Default Results section's UI in the Terminal / Shell section's UI. I would attach a screenshot, but it's either mindbogglingly complex to do so, or it's just not possible.
  12. I'm about to do a clean install on a new Mac. Is it advisable to transfer the preferences from the old to the new, and if so, is it just a matter of copying the old plist file? Or am better off doing it manually?
  13. Whenever I restart my Mac Alfred forgets all my personal keystrokes (Hotkeys). Not sure, but I think this is since the update to yosemite (yes, I already have 10.10.1)
  14. Hello Alfred's Baby Daddy, I'm running Alfred v2 on a late 2011 MacBook Pro, running on Yosemite (10.10.5). I have used Alfred for years without a hitch, and I love this app. In fact, I had no idea just how much I use and rely on this app until it broke for me. However, my problem began when I updated to the latest version of Alfred, v2.7.2 (407). Upon my first reboot after installing the latest version of Alfred, and every startup since, my shortcut to pull up the Alfred search window no longer works. I use Apple key+SPACE to invoke Alfred, but this does not work anymore. This is regardless of focus, i.e. when I click out of my current program to the desktop and try the shortcut, nothing happens. When I do the same thing within an app, same thing: nothing happens. Before today, I've been limping along by opening up the Alfred preferences and then quitting same--without making any changes to preferences--and then trying the shortcut again. Amazingly, it would work once more. I've done this 10-15 times, and while a hassle, I put up with it. Today even this move will not work. I have tried setting the shortcut to a different combination, saving the preferences, and rebooting--same problem with no change. My next thing to try will be an uninstall and reinstall (I hope I don't lose my PowerPack license in the process!). Before I do so, I checked this forum and found no similar complaint. So, I decided to open this report. Thanks!
  15. I had Alfred set to sync its preferences through iCloud Drive to keep them the same across two Macs, but I somehow lost my Powerpack workflows in the process. The preferences for Alfred on one of my computers were reset as well. I have two preferences files in iCloud Drive now, one labeled Alfred.alfredpreferences and the other Alfred 2.alfredpreferences. Deleting the second one returns my preferences to the ones I had, but the workflows are still gone in both files. (checking the folder within the alfredpreferences package) These files are the only Alfred preferences files left on the entire drive. Is it possible to recover the workflows?
  16. On a whim, I decided to start syncing my preferences so I have them backed up consistently. What an unfortunate decision that was.. As soon as I restarted alfred, I found that all my preferences were reset: theme, hotkey, etc... Everything except for my workflows. This was annoying, but it wasn't a huge deal to put everything back. Then I restarted Alfred, and I was back to the default again. This makes Alfred essentially unusable for me, so I hope someone can help me soon—I feel naked using my own machine! Details: Syncing to Dropbox/Miscellaneous/ .plists in user/Library/Application Support/Alfred 2/ are not updated ,nor do they affect behavior I can change prefs in the gui, resulting in appropriate behavior, and overwriting any .plists in the synced .plists These .plists are ignored when Alfred restarts I was able to get sticky preferences by deleting the whole Library folder, and copying in my .alfredpreferences, but although the Worklow data is present, they do not show up in the gui, nor are they usable All I want is for everything to be like it was this morning... It seems to be impossible to turn off syncing in the GUI (a design flaw). Can I do this manually?
  17. I am currently deploying Alfred 2 using Munki. This works great. I would like to deploy some Alfred custom Web Searches that are pre-configured for *all* user accounts on a machine. So far this doesn't work. There are a few possible solutions but what should be an solution seems to not be possible. Or I'm doing it wrong. Afred preferences live in: ~/Library/Application Support/Alfred 2/ But if they could also/instead live in: /Library/Application Support/Alfred 2/ they would be the preferences for all users. Is there any way to make alfred preferences system-wide? If not my plan is to use a program called outset to run a script each time a new user logs in for the first time. The script will copy the Alfred.alfredpreferences package to the appropriate location for the user, then modify permissions/ownership accordingly. Not really difficult but thought it'd be worth asking if someone here can help me better understand what other options might be available. I'm sure there are others.
  18. Suggestion: In Alfred Preferences/Remote, not only do I want to customize the items in each page but I would love to be able to drag and drop them in a different order. Just a thought..............
  19. Hi, my alfred resets its defaultsearch settings every time I reboot or quit/start him. I tried repairing the permissions and I even deleted the preferences files so they can be created from scratch. Also tried setting a sync folder and my Alfred.alfredpreferences file is synced and contains the right values: <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>showArchives</key> <true/> <key>showBookmarks</key> <true/> <key>showDocuments</key> <true/> <key>showImages</key> <true/> <key>showTextFiles</key> <true/> <key>showUserDefined</key> <array> <string>com.apple.disk-image-udif</string> <string>com.apple.generic-internet-location</string> </array> </dict> </plist> Is there something else I can try? I dont want to create a new user account (whichever way this helps, it should also be doable on the current account) and I know I am not the only one having this problem. Thanks guys edit: It seems after the reset, that alfred is not able to create the new preferences files in the directory: /Users/kuba/Library/Application Support/Alfred 2/Alfred.alfredpreferences/preferences altough it has the rights: drwxr-xr-x 2 kuba staff 68B Jul 2 08:50 . drwxr-xr-x 6 kuba staff 204B Jul 2 08:50 .. Curious thing is - one preference is persistent. The sync folder. And it synces whatever changes I make in the preferences to it. I am actually tempted to set the sync folder to the original preferences folder alfred uses, but I'm afraid I could break it edit2: I chmod -R 777 Alfred.alfredpreferences folder and rebooted. So far so good, preferences are kept so solved for me.
  20. Hi, I'm thinking about upload my alfred.Alfredpreferences folder to my Github dotfiles repo and I wanted to know which folders contains sensible data to add them to .gitignore. I know that clipboard and some workflows should be treated as sensible data but I want to know if I should add more folders to this list. Another question I have it's if this UUID contains sensible info too and what's its purpose Alfred.alfredpreferences/preferences/local/<UUID> Thanks!
  21. I am about to release my workflow, http://www.alfredforum.com/topic/5100-regex-run-and-save-regular-expressions/ , onto Packal. The workflow contains a file that contains user data. That is, users can save their own regexs for future use, and those saved regexs are saved in the file. Let's call it MyRegexFile.pl. When I release the next version of my workflow, how can I make it so that user data is not overwritten? * Perhaps there is a special Alfred way to handle updates * Perhaps there is a special Packal way to handle updates * Perhaps the file should be stored elsewhere on the user's computer * Perhaps the file contents should be stored in the keyword script filter itself Those are my ideas. I would like to find the right solution before releasing the new version. I would like the solution to be user friendly. Thanks!
  22. I'm running Alfred 2.4 (274) on the public beta of Yosemite. Alfred runs fine except it seems to forget preference settings. At least, it intermittently forgets the hotkey and theme selection as those are the only preferences I've changed. It is hard to predict when it happens. Sometimes, it will happen after a reboot, but twice it happened while my Mac was up and running. I don't believe a specific Alfred action triggers this behavior.
  23. Navigating through Alfred Preferences can sometimes be not "that" optimal (i.e. switching from "Workflows" to "Features" and from "Features" to "Workflows") from a keyboard point of view. One can use tab to select one menu (General, Features, Workflows, Appearance, Advanced), but when I tried to click nothing happens... I tried to select one of the menu this afternoon, but can't replicate it now...
  24. Hey Andrew, I just did a clean install of OS X Mavericks 10.9.1 and did a fresh clean install of Alfred 2.1.1, too (no workflows, plain fresh and clean), and whenever I try to change a setting or import any skin, on next launch the setting is reset and the skin is gone I have tried repairing disk permissions with no luck, then tried changing the permissions myself with no luck either, then tried enabling sync and set to sync in non-dropbox folder then in dropbox and none worked either I can't do anything without Alfred, so what is happening? Could it be that Alfred is not fully compatible with Mavericks? After trying to "debug" the problem, I noticed the several things: 1. inside the "Alfred.alfredpreferences" package, the file "prefs.plist" found in ./preferences/appearance/options correctly shows that "hidehat=true" & "hidecog=true", which means the settings are persisted 2. however, as soon as I quit and relaunch Alfred, both the hat & cog are visible again, even though the previously mentioned file still shows "hidehat=true" & "hidecog=true", which means that Alfred is not reading the settings it just saved even though the settings are correct in the files on disk.. 3. next test: importing a skin; after importing any skin, it gets saved to the "prefs.plist" found in ./preferences/appearance of the "Alfred.alfredpreferences" package, and gets applied right away 4. but, after half a minute or so upon applying the theme, when I open alfred the theme has changed to the default and inside Alfred's preferences window the theme is gone, even though it still shows up in the previously mentioned "prefs.plist", which means again that Alfred doesn't read its own settings after it persists them?? So the conclusion is this: Alfred saves every setting I make, every change I make, but as soon as I quit/relaunch it all settings from disk are completely ignored. Why isn't Alfred reading the settings it saved? Maybe it's related to Maverick's new & more aggressive preference caching?? Because if a clean Alfred installation on a clean Mavericks installation doesn't work, then it's clearly that Alfred isn't Mavericks-ready yet... I really need Alfred to work, because I refuse to see it become wasted money P.S. while reading the forums, I noticed one other person say this exact phrase: "It seems as though Alfred was saving the settings to that location, but then not reading them back from there." - this confirms that Alfred is not reading back the settings it saves on Mavericks
  25. Nloc - network location switcher for Alfred I use the OS X `network locations` feature quite often. It allows me to comfortably switch between networks, without setting the proxies, DNS and other parameters every time. So I wrote this workflow to do it even faster. Usage: nloc network_location_name Workflow supports autocompletion of known network locations: Download: Up-to-date workflow bundles can be downloaded here. NOTE: Due to changes in security policy on OS X 10.8, system _will_ ask you for your password after executing the workflow. OS X 10.7 system won't ask for your password since it doesn't require the `networksetup` command to be executed with super user privileges.
×
×
  • Create New...