Jump to content

Search the Community

Showing results for tags 'shell script'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Alfred 3
  • Make the Most of Alfred
    • Discussion & Help
    • Bug Reports
    • Alfred Feature Suggestions
    • Themes
  • Alfred Workflows
    • Share your Workflows
    • Workflow Help & Questions
  • Alfred v2 Themes
  • Alfred Remote for iOS
    • Alfred Remote Discussion & Help
    • Remote Connection Troubleshooting

Categories

  • Articles
    • Forum Integration
    • Frontpage
  • Pages
  • Miscellaneous
    • Databases
    • Templates
    • Media

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Twitter


Website URL


Jabber


Location


Interests

Found 3 results

  1. I can't seem to get Alfred to run a pandoc conversion to pdf. Neither of the pandoc commands bellow will run in Alfred but I have confirmed that xelatex and pdflatex are installed, and both run perfectly fine in Terminal and from my FastScripts menu, so it seems the issue is with Alfred. I am specifying the full path to pandoc (/usr/local/bin/pandoc) so this is not a path issue (as mentioned here: https://github.com/shawnrice/alfred-documentation/wiki/Environmental-Variables). I'm fairly certain it's exclusively a PDf (xelatex, pdflatex) issue because pandoc conversions to HTML run perfectly fine for me in Alfred. This syntax is directly from Pandoc Demos (https://pandoc.org/demos.html) and runs perfectly fine in my Terminal: /usr/local/bin/pandoc ~/Desktop/MANUAL.txt --pdf-engine=xelatex -o ~/Desktop/example13.pdf But produces the following error when called within a "Run Script" action (Language /bin/bash/) in Alfred: [ERROR: action.script] xelatex not found. Please select a different --pdf-engine or install xelatex This syntax also runs perfectly fine in Terminal: /usr/local/bin/pandoc ~/Desktop/MANUAL.txt -o ~/Desktop/example13.pdf But produces the following error when called within a "Run Script" action (Language /bin/bash/) in Alfred: [ERROR: action.script] pdflatex not found. Please select a different --pdf-engine or install pdflatex Both of these also fail with I run them in an external shell script called from Alfred. What am I missing?
  2. I am going a little nuts, I know I must be doing something wrong (since its not working) but I can't figure it out. I installed and configured Rumember - from terminal executing: ru pick up the milk ^Today #Personal works just fine and adds to RTM. I have then setup a workflow in Alfred that on typing 'r {query}' it would execute a shell script. I tried to different methods to get this to work: METHOD 1 ru {query} METHOD 2 shopt -s expand_aliases if [ -f "${HOME}/.bash_profile" ] ; then source "${HOME}/.bash_profile" fi ru {query} & Neither method works, no errors , nothing in bash history just blank. Any help would be great! Thanks
  3. Hi, sorry if this topic has come up before but i haven't found any proper answers for this yet: Is there a way to properly set the output of shell scripts in the workflows? for example some kind of variables to set to put into the fields "title" and "text" ? in alfred1 i just "echo"'d stuff inside of the script which was taken as input to the notification centre but now i have some trouble to do this correctly.... maybe i'm doing it wrong, but then again, sometimes i would like to have 2 variables displayed as title and text ... is there any way? kind regards fabian
×
×
  • Create New...