19000

Hotkey Trigger not reading text selection when Chinese/Japanese input source enabled

9 posts in this topic

When the OS X built-in Chinese/Japanese input source is enabled the Hotkey Trigger fails to read text selection. It's easy to replicate. And it's still not very efficient when people have to switch to English in order to make it work if one switch between these languages constantly.

Any improvement over this issue?

Thanks in advance for your attention!

 

p.s. I saw my last post got deleted but that's related to this case and I actually spent pretty much time on searching and testing to figure out that.

Edited by 19000

Share this post


Link to post
Share on other sites
7 minutes ago, 19000 said:

p.s. I saw my last post got deleted but that's related to this case and I actually spent pretty much time on searching and testing to figure out that.

 

It was not deleted, it was hidden. From your last posting there (“I figured it out myself, it was caused by the input method. Sorry to be bothering.”) and considering no one else had replied or experienced that problem, it didn’t seem relevant to keep it there.


I’ve unhidden it. Feel free to continue there.

Edited by vitor

Share this post


Link to post
Share on other sites

@19000 I've been experimenting with this, including using various different input sources for Chinese and Japanese. In all instances, using a Hotkey trigger to use the Selection in macOS has worked exactly as expected.

 

Do you use any keyboard modifier apps or other clipboard tools that may be interfering and making it difficult for Alfred to copy the selection to clipboard?

 

Take a look at any apps listed in System Preferences > Security & Privacy > Privacy > Accessibility. I would recommend disabling all apps aside from Alfred Text Service, and re-enabling them one at the time to see whether you can identify what may be conflicting.

 

Cheers,

Vero

Share this post


Link to post
Share on other sites

Thanks for the reply!

I disabled all the apps in "Accessibility" and it still not work with Chinese and Japanese input sources. Now it's quite tough to solve since there's no problem on your machine.

 

Here's my settings.

All of them have been disabled and Alfred wasn't even in the list before I manually added it, but since it worked fine in English mode and the problem wasn't solved after adding and enabling Alfred in it I guess it has nothing to do with this setting?

Any further suggestions?

58ac8040b2691_ScreenShot2017-02-22at1_49_38AM.png.79d93ee04ea249bcae1c3e719e77fa17.png

58ac803e4bcc6_ScreenShot2017-02-22at1_50_18AM.png.3ae937535acdc4b88aeb165f47a8a38c.png

Share this post


Link to post
Share on other sites

@19000 Taking a look at your screenshots and your license, it looks like you're still using Alfred 2?

 

I've tested this issue with Alfred 3, but please bear with me a few days and I will aim to test this further in Alfred 2 as well. :)

 

In the meantime, I would recommend creating a temporary second user account on your Mac, and checking whether you encounter the same behaviour without the other apps you have installed on your primary user account. This will help narrow down whether it's a conflict issue with another app.

 

Cheers,
Vero

Share this post


Link to post
Share on other sites

@Vero Yeah it's Alfred 2. After testing in a fresh environment I found there's something wrong with Dvorak layout, which may be easy to replicate on your machine, and it worked well with the default layout. 

 

Here's the screenshots I took. I selected some text in the web page and trigger the workflow with different input sources which you can verify from the upper-right of the screen. Also, the Japanese setting panel and the Alfred workflow window were put in the picture for your reference.

Note the Japanese one has the keyboard layout options in its own panel while the Chinese one maybe just follows the English layout outside.

 

58b5d4df9893d_ScreenShot2017-03-01at2_16.15AMcopy.thumb.jpg.902ba119ccd0aead84d14078475c80b2.jpg

 

58b5d4e4bfd20_ScreenShot2017-03-01at2_17.29AMcopy.thumb.jpg.8f180d83a5ac7892aad7ee08590be08e.jpg

 

 

 

 

58b5d4dd88c10_ScreenShot2017-03-01at2_16.02AMcopy.thumb.jpg.36943c078344669f4ca27454150d7a88.jpg

 

58b5d4e17d440_ScreenShot2017-03-01at2_16.37AMcopy.thumb.jpg.32450569535020bca7b20661a6694cff.jpg

 

58b5d4e35ec29_ScreenShot2017-03-01at2_17.19AMcopy.thumb.jpg.590165a747f167165778f7788a50fe09.jpg

 

58b5d4e6c29aa_ScreenShot2017-03-01at2_18.06AMcopy.thumb.jpg.b202b79651534be05e46708323942268.jpg

 

 

Share this post


Link to post
Share on other sites

@19000 You may need to select "Dvorak-Qwerty" instead of "Dvorak", as this maintains the standard locations for the cmd modifier keys which would allow the simulated copy to continue working.

Share this post


Link to post
Share on other sites

@Andrew Now it passes the Japanese and Chinese but fails the English (Dvorak - Qwerty Cmd). And personally I'm not very comfortable with this "Dvorak - Qwerty Cmd" layout as it changes behavior when holding Cmd key.

Moreover, I have a LaunchBar installed in which there's a similar functionality called "Instant Send" and after testing it doesn't have any problem with all these input methods and layouts, so I guess it has nothing to do with those layout choices in order to copy the texts?

 

58b5e8b66a55c_ScreenShot2017-03-01at4_46.55AMcopy.thumb.jpg.577fd25c9fd1c24b6e69f453255d253b.jpg

 

58b5e8b475a49_ScreenShot2017-03-01at4_47.02AMcopy.thumb.jpg.9456fb144f9e1efffa4734d44c348a3c.jpg

 

58b5e8b2777e3_ScreenShot2017-03-01at4_47.14AMcopy.thumb.jpg.69d7e1a98a6802bf8fc2a762134947ec.jpg

Share this post


Link to post
Share on other sites

Hi @19000 

 

Thanks for your patience and sorry about the delay in testing this on Alfred 2. :) I've spent a good while testing this and I can see that in certain keyboard scenarios, pressing the hotkey will result in the selected text flashing yellow (in the way it does when you select text then choose "Look up [text]" which pops up the Dictionary panel) then shows an empty Alfred field.

 

In Alfred 3, Andrew completely overhauled the way multiple keyboards and languages are handled, so that behaviour is much improved in v3. As this was a significant change, it won't be retroactively added to Alfred 2.

 

I'll be moving this to Closed at this point, as we've been able to confirm the issue doesn't affect the current version of Alfred.

 

Cheers,
Vero

Share this post


Link to post
Share on other sites