Jump to content
erip

Cannot update Alfred behind proxy

Recommended Posts

Version of OS X: 10.12.3 (16D32)

Version/build of Alfred: v3.3/801

Expected behavior: When checking for updates, be able to connect to remote update server for updates.

Actual behavior: Unable to contact update server. Unable to load changelog.

 

Reproduce

1. Be behind proxy

2. Set `$http_proxy`, `$https_proxy`, `$HTTP_PROXY`, `$HTTPS_PROXY` in environment.

3. Check for updates...

Optional: toggle use macOS proxy in network in Alfred -> advanced settings. Try step 3 again.

 

I'd love some guidance on this. FWIW, this worked before upgrading to Sierra. 

 

P.S., great tool! Very helpful. Thanks for sharing!

 

Cheers,

erip

 

Share this post


Link to post
Share on other sites
1 hour ago, erip said:

Set `$http_proxy`, `$https_proxy`, `$HTTP_PROXY`, `$HTTPS_PROXY` in environment.

 

What do you mean by this? How/where did you set those variables?

 

They will, in any case, be ignored by Alfred and other native applications.

 

1 hour ago, erip said:

toggle use macOS proxy in network in Alfred -> advanced settings

 

This only affects workflows, AFAIK, not Alfred's own behaviour.

 

Like most native applications, Alfred uses your system proxy settings (System Preferences > Network > Advanced > Proxies). The above setting affects the values Alfred sets for http_proxy and https_proxy when it runs workflow scripts.

Share this post


Link to post
Share on other sites

They were set in my ~/.bashrc.

 

My http and https proxies are also set in System Preferences > Network > Advanced > Proxies, along with the location of my corporate .pac file.

Share this post


Link to post
Share on other sites

None of your Mac applications care about ~/.bashrc or other UNIX dotfiles. Your login session is started via launchd, not a shell, so it inherits launchd's almost empty environment.

 

Alfred itself should work with both a .pac file and manually-configured proxies, but most workflows won't work with a .pac file.

 

Are you having issues with any other applications?

 

Does your corporate network man-in-the-middle HTTPS connections? If so, Alfred may be rejecting the incorrect certificate.

Share this post


Link to post
Share on other sites

Yes, I'm having problems with Docker (only updating); however, I think that's a separate issue

 

My corporate network does MitM HTTPS connections AFAIK... but I know others in my organization have gotten Alfred to work with the proxy. Quite intriguing. 

Share this post


Link to post
Share on other sites
13 minutes ago, erip said:

I know others in my organization have gotten Alfred to work with the proxy

 

They've got Alfred to work but have they got it to update? Could be due to certificate pinning.

 

I'm all out of ideas, in any case.

 

Perhaps @Andrew can help?

Share this post


Link to post
Share on other sites

@erip If it's certificates-related as @deanishe suggests, it could be due to the GlobalSign issue from back in October.

 

GlobalSign had issues with its certification for a few hours in October. The issue itself was quickly resolved, but a small number of users' certificates didn't seem to update. 

Here's the documentation provided by GlobalSign to clear certificate caches (scroll down for Mac version)


https://support.globalsign.com/customer/portal/articles/1353318

 

You can then restart your Mac. This will clear cached certificates for any websites you visit, so your Mac will acquire new certificates next time you visit them.

 

Cheers,
Vero

 

Share this post


Link to post
Share on other sites

I found the problem. Very interesting. In the System Preferences > Network > Advanced > Proxies > HTTP & HTTPS, I had prefixed `http` to my proxy, which caused an issue. If anyone reports this issue, this might be a silly reason. :) Thanks for the help!

Share this post


Link to post
Share on other sites

×
×
  • Create New...