Jump to content

[PYTHON FIX] How to fix Python workflows hanging Alfred on Sierra


Recommended Posts

There is a bug in my (unofficial) Alfred-Workflow library that causes very many workflows using it to hang quite dramatically on Sierra.

 

If you are affected (i.e. you see Alfred's CPU usage spike to 100%), Activity Monitor will show two Python processes like this (choose View > All Processes, Hierarchically), with the bottom one at ~99% CPU (this screenshot is actually of a non-misbehaving workflow):

 

1IwbtpY.png

 

Download and run this workflow, which will update any old versions of Alfred-Workflow in your installed workflows.

 

That should get your workflows working again until the workflow developers can push official fixes.

 

Edited by deanishe
Replace IPB with an image service that works
Link to post
  • 3 months later...
  • 2 years later...

@deanishe I was looking at the pinned threads. Perhaps this one is safe to unpin, as this bug was so long ago it’s unlikely any user is still bitten by it.

 

Commenting instead of unpinning myself because I don’t want to step on your toes, it being your post. Feel free to delete my comment either way, to keep the thread clean.

Link to post
11 minutes ago, vitor said:

Perhaps this one is safe to unpin, as this bug was so long ago it’s unlikely any user is still bitten by it.

 

TBH, it probably still happens, as some workflows just haven't been updated since then. But, yeah, we should unpin it because Alfred will warn the user itself if a workflow is incompatible. Good call.

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...