matias

Alfred can't find Xcode.app

2 posts in this topic

For some reason Alfred (v3.3.2) can't find Xcode on my macOS Sierra MBP (10.12.5).

 

I installed Xcode normally via the App Store to /Applications. I also tried to reset the Alfred search scopes, but that didn't help.

 

As far as I can tell, Xcode is the only application that Alfred can't find (aside from the other developer tools in /Applications/Xcode.app/Contents/Applications)

2017-05-17_11-20-54_tpm1l.png

Screen Shot 2017-05-17 at 11.17.34.png

2017-05-17_11-23-05_h5nh4.png

Share this post


Link to post

@matias Alfred relies on your Mac's index, so if it's a little out of date, or corrupted, apps can be missing from results.

 

The first way to reindex just a single app is to pop up Spotlight preferences to the Privacy tab, drag the app (or the Applications folder) in, wait 30 seconds, then drag it back out. Wait a few minutes, and your Mac should reindex that folder. Once that's done, type "reload" into Alfred, as Alfred keeps an application cache for quick results.

 

If this doesn't resolve the issue, take a look at step 4 here, which is a full reindex:

https://www.alfredapp.com/help/troubleshooting/indexing/

 

Let me know how you get on :)

 

Cheers,
Vero

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now