Jump to content
GuyVerville

Aflred Text's Expansion does not show on preferences

Recommended Posts

Hi,

I have tried to activate Alfred's Text Expansion on the Preferences Accessibility tab. However, it doesn't show there... I quit Alfred and start it again, same message telling me I must activate it in the Preferences Accessibility tab. Any idea?  Using Sierra 10.5.2

 

597523d1e1ea8_PreferencesSystemeScreenSnapz001.thumb.png.563f6b1be6d7cb2233a2c62a030e3f5a.png

Share this post


Link to post

@GuyVerville Welcome to the forum!

 

First, ensure you're using the latest Alfred 3.4.1. When following the steps to add Alfred Text Service to your Accessibility preferences, you should see these steps:

https://www.alfredapp.com/help/features/snippets/auto-expansion/

 

If you need to manually add Alfred Text Service, you can do so by clicking the + at the bottom of the list and adding it from the following path:

/Applications/Alfred 3.app/Contents/Services/Alfred Text Service.app

 

To get to the contents of Alfred's package, right-click Alfred 3 itself in your Applications folder, and choose "Show Package Contents" to navigate into it

 

Let me know how you get on :)

Share this post


Link to post

I'm having the same problem.  @Vero how do I manually add it?  I'm clicking the + icon but see no place to put the path.  I tried right clicking Alfred 3 in the dialog box but there isn't a choice show package contents.  I'm using macOS 10.13.2

Edited by ae6dx

Share this post


Link to post

@ae6dx You can pop up Alfred, paste in the path, then use the right arrow to show File Actions and Reveal in Finder. You can then simply drag it to the Accessibility window. 

 

You may have to first type in your user account password, if the lock is closed at the bottom of the Accessibility window.

 

Cheers,
Vero

Share this post


Link to post

Hello,

 

I have the same question: "alfred text service" doesn't appear in System Preferences (see attached ).

I tried adding it manually, but the path "/Applications/Alfred 3.app/Contents/ Service s/Alfred Text Service.app" doesn't exist (see attached).

 

Could you please help?

 

Thank you,

 

Gabor

2019-03-10_22-52-08.jpg

2019-03-10_22-57-05.jpg

Share this post


Link to post

@grevesz There has been a subtle change since the earlier posts in this thread, and "Alfred 3" is what is being added to accessibility instead. Based on your screenshot, you're good to go!

 

If you're having issues with Text Expansion, please provide more details and we'll be happy to help:

 

- What version of macOS and Alfred are you using?

- Are you setting up Text Expansion for the first time? Or did it stop working after you'd already used it?

- How far through text expansion does it get, e.g. Does your snippet disappear when typed? Do you hear an error beep? Does it paste partially?

- Please include screenshots of your Snippets prefs

 

Cheers,
Vero

Share this post


Link to post
Posted (edited)

Hello Vero,

 

Thanks for the quick response. It works perfectly now.

 

Thanks again and best regards,

 

Gabor

Edited by grevesz

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...