Jump to content
vitor

PinPlus — Interact with your Pinboard bookmarks

Recommended Posts

Update.

 

When sending to DownVid, default to video.


To update, download the latest version (same URL) or wait a few days and it’ll prompt you to on next usage, since it uses OneUpdater.

Share this post


Link to post

Update.


Added option to auto fetch bookmarks every hour.


To update, download the latest version (same URL) or wait a few days and it’ll prompt you to on next usage, since it uses OneUpdater.

Share this post


Link to post
3 hours ago, ng4ever said:

How do I improve the Pinboard.in GUI in windows please? Thanks.

 

You can add a UserScript to your browser, for example.

 

3 hours ago, ng4ever said:

I know I can't use PinPlus

 

Sure you can. It’s an Electron app, so you can build it in Windows. But like I mention:

 

Quote

Currently, only macOS is supported. I do not intend to officially support other platforms in the near future since I cannot consistently and reliably test on them, but am willing to add support if someone wants to collaborate in doing the legwork.

 

Share this post


Link to post
9 hours ago, ng4ever said:

Thanks but I don't even know where to start.

I am not a programmer. :(

 

Unfortunately, I can’t help you, as I’m not a Windows user.

 

If you’re not even an Alfred user, then you’re definitely in the wrong place.

Share this post


Link to post

Update.


Display information while looking for new PinPlus app version (with :pinplusupdateapp).


To update, download the latest version (same URL) or wait a few days and it’ll prompt you to on next usage, since it uses OneUpdater.

Share this post


Link to post

Update.


I’ve made slight modifications to the method to read/write api token. You will be asked to add your token again.


To update, download the latest version (same URL) or wait a few days and it’ll prompt you to on next usage, since it uses OneUpdater.
 

Share this post


Link to post

Update.


Added support for Vivaldi and Brave. I’ve skipped Opera since while we can get the URL and Title from a tab, we can’t execute JavaScript (to run the bookmarklet to add bookmarks). The capability seems to be there (being Chromium-based) but not a way of turning it on.


To update, download the latest version (same URL) or wait a few days and it’ll prompt you to on next usage, since it uses OneUpdater.

Share this post


Link to post

Update.


Better messaging when looking for new PinPlus app version.


To update, download the latest version (same URL) or wait a few days and it’ll prompt you to on next usage, since it uses OneUpdater.

Share this post


Link to post

If you’ve been having trouble with the PinPlus app sometimes not opening, I’ve released a fix. Call :pinplusupdateapp in Alfred and it’ll update itself.

Share this post


Link to post

Updated for Alfred 4.


To update, download the latest version (same URL) or wait a few days and it’ll prompt you to on next usage, since it uses OneUpdater.
 

Share this post


Link to post
52 minutes ago, Sridhar Katakam said:

Is there any way to disable the tag cloud in the window that appears after `pa`?

 

Tag autocomplete, not tag cloud. No way to disable it, no; that window is from the Pinboard site.

Share this post


Link to post
3 hours ago, Sridhar Katakam said:

btw, I am talking about the following and not tag auto complete.

 

You just need to change the URL:

 

image.thumb.png.eeb171cdb320e624bb4c32c1ca91e419.png

 

Remove showtags=yes& and the tag cloud won't be shown.

Share this post


Link to post

Hi,

 

for some reason it doesn't show me any of my pins. It says "fetching bookmarks" for a second and then nothing happens. I was using Rusty Pin before, but when I updated to Alfred 4, it stopped working. After a quick search, I found your (updated) workflow but it doesn't work either. I can add bookmarks with both workflows but for some reason I can't get to see or search them in Alfred. Any clues about that?

Share this post


Link to post

@Heidern

 

Have you setup your API token? Redo it with :pinplusresetapitoken.


If that doesn’t work, open the debugger, set the log output to “All Information”, and post the output of pin.

Share this post


Link to post

Ok, I did this,  but no success.

 

Here's the debugger output:

 

[18:21:40.766] Logging Started...

[18:21:45.194] PinPlus[Script Filter] Queuing argument '(null)'

[18:21:46.256] PinPlus[Script Filter] Script with argument '(null)' finished

[18:21:46.258] ERROR: PinPlus[Script Filter] Code 1: /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/open-uri.rb:359:in `open_http': 401 Forbidden (OpenURI::HTTPError)

from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/open-uri.rb:737:in `buffer_open'

from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/open-uri.rb:212:in `block in open_loop'

from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/open-uri.rb:210:in `catch'

from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/open-uri.rb:210:in `open_loop'

from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/open-uri.rb:151:in `open_uri'

from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/open-uri.rb:717:in `open'

from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/open-uri.rb:35:in `open'

from /Users/ingo/Library/Application Support/Alfred/Alfred.alfredpreferences/workflows/user.workflow.164BA2E6-9E46-4BD0-8DE7-0C538A8B83FD/pinplus.rb:103:in `unsynced_with_website?'

from /Users/ingo/Library/Application Support/Alfred/Alfred.alfredpreferences/workflows/user.workflow.164BA2E6-9E46-4BD0-8DE7-0C538A8B83FD/pinplus.rb:156:in `fetch_bookmarks'

from /Users/ingo/Library/Application Support/Alfred/Alfred.alfredpreferences/workflows/user.workflow.164BA2E6-9E46-4BD0-8DE7-0C538A8B83FD/pinplus.rb:148:in `show_bookmarks'

from /Users/ingo/Library/Caches/com.runningwithcrayons.Alfred/Workflow Scripts/DAF696E7-873D-49A5-94E6-B8403A707D81:3:in `<main>'

Share this post


Link to post
9 minutes ago, Heidern said:

Do you know what the error means?

 

it means you aren’t authenticated, which means your API token is either not set, or wrong. Have you done this part?

 

11 hours ago, vitor said:

setup your API token? Redo it with :pinplusresetapitoken.

 

Make sure you get your API token from https://pinboard.in/settings/password.

Share this post


Link to post

I'm sorry, can you please tell me how to set the token? Where do I put it in?

I've done the :pinplusresetapitoken command but it's just showing me the link you've posted.

Adding bookmarks still works btw.

 

Thanks for your help!

Share this post


Link to post
2 minutes ago, Heidern said:

I've done the :pinplusresetapitoken command but it's just showing me the link you've posted.

 

That’s a text box. Paste your token there.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...