Jump to content
vitor

PinPlus — Interact with your Pinboard bookmarks

Recommended Posts

Update.


When opening bookmark in Pinboard, remove the protocol from the search.


To update, download the latest version (same URL) or wait a few days and it’ll prompt you to on next usage, since it uses OneUpdater.

Share this post


Link to post

Works great -- thank you developer. The only Pinboard workflow I've managed to get (stably) working on Alfred 4 :)

Edited by noodles5

Share this post


Link to post

Update.

 

Added unread_order Workflow Environment Variable to control how unread bookmarks are displayed (oldest or newest first).


To update, download the latest version (same URL) or wait a few days and it’ll prompt you to on next usage, since it uses OneUpdater.
 

Share this post


Link to post

Does the PinPlus workflow work in Firefox? I've install the workflow but the 'pa' command in Alfred doesn't do anything for me. If I install the `PinPlus` app, the GUI pops up but the URL isn't inserted. I've tried this in Firefox (69.0.3) and using the latest version of PinPlus (1.6.0). Here is the debug report from Alfred for the 'pa' command:

 

[12:03:55.754] Logging Started...
[12:04:12.057] PinPlus[Keyword] Processing complete
[12:04:12.059] PinPlus[Keyword] Passing output '' to Run Script
[12:05:02.933] STDERR: PinPlus[Run Script] 2019-10-11 12:04:12.849 PinPlus[93087:8272687] *** WARNING: Textured window <AtomNSWindow: 0x7fed24539600> is getting an implicitly transparent titlebar. This will break when linking against newer SDKs. Use NSWindow's -titlebarAppearsTransparent=YES instead.
[12:05:02.937] PinPlus[Run Script] Processing complete
[12:05:02.938] PinPlus[Run Script] Passing output '' to Run Script

Edited by capac
Amended format

Share this post


Link to post
1 hour ago, capac said:

Does the PinPlus workflow work in Firefox?

 

No. Firefox does not integrate with Alfred and similar tools because it doesn't support AppleScript.

Share this post


Link to post

Update.


Use cache dir instead of data dir.


To update, download the latest version (same URL) or wait a few days and it’ll prompt you to on next usage, since it uses OneUpdater.
 

Share this post


Link to post

Update to version 20.5 seems to have broken this brilliant workflow on my system, it has worked flawlessly for a long time. 

I'm on macOS 10.14.6 (Mojave), Alfred 4.0.9, and using version 20.5 of this workflow. I paste info from the debugger below. 

[14:57:34.066] Logging Started...
[14:57:38.788] ERROR: PinPlus[Script Filter] Code 1: /Users/*******/Library/Application Support/Alfred/Alfred.alfredpreferences/workflows/user.workflow.4064276A-EABF-45AA-8CC9-180353BE7304/pinplus.rb:104:in `synced_with_website?': private method `open' called for URI:Module (NoMethodError)
    from /Users/*******/Library/Application Support/Alfred/Alfred.alfredpreferences/workflows/user.workflow.4064276A-EABF-45AA-8CC9-180353BE7304/pinplus.rb:154:in `fetch_bookmarks'
    from /Users/*******/Library/Application Support/Alfred/Alfred.alfredpreferences/workflows/user.workflow.4064276A-EABF-45AA-8CC9-180353BE7304/pinplus.rb:147:in `show_bookmarks'
    from /Users/*******/Library/Caches/com.runningwithcrayons.Alfred/Workflow Scripts/D583D1C2-544A-40BD-A789-E4A0F7A64A40:3:in `<main>'

 

Share this post


Link to post
3 minutes ago, cands said:

Update to version 20.5 seems to have broken this brilliant workflow on my system, it has worked flawlessly for a long time. 

I'm on macOS 10.14.6 (Mojave), Alfred 4.0.9, and using version 20.5 of this workflow. I paste info from the debugger below. 


[14:57:34.066] Logging Started...
[14:57:38.788] ERROR: PinPlus[Script Filter] Code 1: /Users/*******/Library/Application Support/Alfred/Alfred.alfredpreferences/workflows/user.workflow.4064276A-EABF-45AA-8CC9-180353BE7304/pinplus.rb:104:in `synced_with_website?': private method `open' called for URI:Module (NoMethodError)
    from /Users/*******/Library/Application Support/Alfred/Alfred.alfredpreferences/workflows/user.workflow.4064276A-EABF-45AA-8CC9-180353BE7304/pinplus.rb:154:in `fetch_bookmarks'
    from /Users/*******/Library/Application Support/Alfred/Alfred.alfredpreferences/workflows/user.workflow.4064276A-EABF-45AA-8CC9-180353BE7304/pinplus.rb:147:in `show_bookmarks'
    from /Users/*******/Library/Caches/com.runningwithcrayons.Alfred/Workflow Scripts/D583D1C2-544A-40BD-A789-E4A0F7A64A40:3:in `<main>'

 

 

Ah, I now saw that there is already a version 20.6 available to download (not yet recognized by OneUpdater, should have checked manually before posting...) which seems to have fixed this, working well again, thanks! 

Share this post


Link to post

Update.


Added a Hotkey to open a random unread bookmark. Useful to start dealing with your unread bookmarks without having to deal with choosing them.


To update, download the latest version (same URL) or wait a few days and it’ll prompt you to on next usage, since it uses OneUpdater.
 

Share this post


Link to post

Hi all,

 

I got a new MBP (work) and it killed my favorite alfred workflow. Error below.

 

Details:

MBP Pro 2019 - Catalina V10.15.5 

Pinplus 20.8 

 

Based on some threads above, I generated a new API token and updated the token in Alfred. The workflow is fine on my personal MBP (2013, Catalina V10.15.5 ). 

 

Any ideas on what could have happened?

 

 

ERROR: PinPlus[Script Filter] Code 1: /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/open-uri.rb:378:in `open_http': 500 Internal Server Error (OpenURI::HTTPError)

from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/open-uri.rb:756:in `buffer_open'

from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/open-uri.rb:226:in `block in open_loop'

from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/open-uri.rb:224:in `catch'

from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/open-uri.rb:224:in `open_loop'

from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/open-uri.rb:165:in `open_uri'

from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/open-uri.rb:736:in `open'

from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/open-uri.rb:744:in `read'

 

Share this post


Link to post
1 hour ago, kallsey said:

Any ideas on what could have happened?

 

That's a server error, not a client error. Have you been getting the error for some time?

Share this post


Link to post
On 6/2/2020 at 4:56 PM, deanishe said:

 

That's a server error, not a client error. Have you been getting the error for some time?

 

Only my personal macbook pro no, on this one, the errors have been happening from the time I installed. 

Share this post


Link to post

Hi all, I'd really love to get this up and running. 

 

I'm on macOS 10.14.6 with ruby 2.3.7p456 (2018-03-28 revision 63024). This is what I get on running "pin". (API key is set)  

[14:36:11.222] PinPlus[Script Filter] Queuing argument '(null)'
[14:36:12.263] PinPlus[Script Filter] Script with argv '(null)' finished
[14:36:12.266] ERROR: PinPlus[Script Filter] Code 1: /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/json/common.rb:156:in `parse': 784: unexpected token at '{"update_time":"2020-06-14T15:51:27Z"} (JSON::ParserError)

 

Side note: I also have ruby 2.7.1p83 (2020-03-31 revision a0c7c23c9c) installed via rvm but I can't seem to get the workflow to use it. Already searched stack overflow but getting nowhere. So I figured I'd ask. Would really appreciate a pointer in the right direction. 

 

 

Share this post


Link to post
4 hours ago, patowod said:

Would really appreciate a pointer in the right direction.

 

Read the post above yours. This is an issue with the API we’re waiting to get resolved.

Share this post


Link to post

I’ve emailed Maciej early on about this issue. It started after a major server upgrade and he is investigating. It’s taking longer to be fixed than I was expecting, so I’ve decided to build a workaround into the Workflow, which I’ll remove when this is fixed.

 

If you don’t want to wait for the API issue to be resolved, download the latest version.

Share this post


Link to post
10 minutes ago, vitor said:

I’ve emailed Maciej early on about this issue.

 

I emailed him earlier today. He says he's working on it. Hasn't tracked down which bit of the code is adding the BOM yet.

Share this post


Link to post
15 minutes ago, deanishe said:

He says he's working on it. Hasn't tracked down which bit of the code is adding the BOM yet.

 

Yes, that’s the reply I got as well. I first tweeted at him five days ago to confirm something had changed, then tracked down what was causing the problem (on the Workflow, the JSON library wasn’t being able to parse the responses) and emailed him the details. Since then, more people on Twitter bumped into the issue. He replied by email yesterday that he was looking into it.

 

I was expecting this to be a simple fix upstream (maybe two days, tops), but since it’s taking a while to find the cause and we have no ETA (and I’m missing the ability to use the Workflow), figured it would be best to just add the workaround and be done with it.

 

I’ve made a small script which I’m running on occasion to check if the problem is still there. As soon as it’s fixed, I’ll remove the workaround.

 

Good news for users of the Workflows is that you essentially no longer have to worry about it. Even when this is fixed, the workaround won’t break on the correct behaviour.

Share this post


Link to post
3 minutes ago, vitor said:

Yes, that’s the reply I got as well.

 

Yeah, I don't get the impression he's looking as hard as he could be. Too busy posting political stuff on Twitter.

Share this post


Link to post

The API issues have been solved (not everywhere), so I’ve removed the workaround from the Workflow. Also took the chance for the subtle icon update.

 

You usage should be unaffected.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...