Jump to content

Alfred loses focus when running a list filter workflow


nikivi
 Share

Recommended Posts

I had this issue before and @deanishe said the issue was due to me having to many list filters. Now there is one list filter and one script filter reading JSON directly just as @deanishe said to do. It should be correct.

 

And yet, I get behaviour that I can't use my workflow, it just disappears. And the weirdest part is that if I go to Alfred Preferences and activate my workflow there. It works. :| 

 

Here is a screencast of the bug : http://quick.as/aVkOHdwAo

 

Here is the workflow I am using. 

 

Quitting Alfred and starting it again, stops the behaviour. However after 20 maybe more minutes it comes back. 

 

Thank you for any help.

Link to comment
Share on other sites

@nikivi It's difficult to understand exactly what's happening without an actual explanation, but by "bugging out", do you mean that the Alfred window loses focus before you've pressed return or chosen your item from the list?  If I interpret correctly what you're trying to show, it looks like something is stealing focus from Alfred.

 

As far as the List Filter object goes, there's nothing special about it, so there's no reason for it to disappear before you make your selection.

 

Have you tried running your workflow on a completely fresh user account/Mac? I can't see your Mac's menu bar in the screen capture, but please take a look at the apps and menubar tools you're using, just in case one of these is trying to take over focus? Temporarily disable anything non-essential in Accessibility and any keyboard modifiers.

 

Cheers,
Vero

Link to comment
Share on other sites

I think you are right in that Alfred loses focus from the list filter. If I restart my laptop and try use the workflow again, everything works perfectly so the issue is then in some other application I am running, only problem is I have no idea how to pinpoint which one as I run quite a few of them. Will try to start afresh and hopefully I can find which app messes with losing of the focus of the workflow.

 

The strange thing is that it happens with my workflow only. Any other workflow I run will still work perfectly well. That's why I assume something was indeed with the way I made the workflow perhaps or how I connected the List Filter or something. And also strange that it works only in Alfred Preferences, if you go outside of it, the issue is there. My only guesses it would be something related to Hammerspoon but I don't use it for anything major and the issue starts occurring rather 'randomly'.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...