Jump to content
eibrahim

Almost all workflows are failing for me

Recommended Posts

I have wasted so much time on this :(.  Almost all workflows throw the same error: "No such file or directory" and when I look in the debug tab for the workflow, I see that most workflows are looking for files in "Alfred 2" folder but I have "Alfred 3".  Is there a fix for this? most workflows are unusable for me.

 

Even Packal Updater throws this error:

/Users/eibrahim/Library/Application Support/Alfred 2/Workflow Data/alfred.bundler-aries/assets/utility/terminal-notifier/default/Contents/Resources/Terminal.icns: No such file or directory

Share this post


Link to post

Hi @eibrahim Welcome to the forum! :)

 

You'll only see this behaviour when a workflow creator has hard-coded the folder path (e.g. when they created the workflow originally for Alfred 2), as Alfred otherwise respects the version you're using, creating the folder in the right place.

 

First, I'd recommend searching on the forum for a newer version of the workflow, as many have been updated to Alfred 3 at some stage, but not all workflow creators necessarily use Packal these days (as this was a user-created website which is no longer actively maintained). 

 

Alternatively, you can simply create the folder the workflow is looking for manually, which will also resolve the issue you're seeing.

 

Cheers,
Vero

Share this post


Link to post

I am just having issues with everything.  i am a techie and struggling to make simple workflows work.  not sure what's going on, i have wasted so much time which is the exact opposite of what I am trying to achieve with Alfred :).  

 

How do I remove everything and start from scratch? :(

Share this post


Link to post

@eibrahim Could you share links of specific workflows you're trying to use so that we can help you more precisely, or point you in the right direction? 

 

You can remove any workflow you don't want to use by right-clicking the name of a workflow in the sidebar and choosing "Delete".

 

Cheers,
Vero

 

 

Share this post


Link to post

I have been at it and so far the only one that doesn't work is Packal Updater.  when i type packal, I get this notification https://goo.gl/wMhb1G and I see https://goo.gl/8dHuQ5 when I click open Graphical application i get https://goo.gl/5NSiEG

and in the debug tab, this is what i see

 

[2017-08-29 12:34:55][STDERR: input.scriptfilter] mv: rename alfred-bundler-aries/includes to /Users/eibrahim/Library/Application Support/Alfred 2/Workflow Data/alfred.bundler-aries/includes: Directory not empty
mv: rename alfred-bundler-aries/meta to /Users/eibrahim/Library/Application Support/Alfred 2/Workflow Data/alfred.bundler-aries/meta: Directory not empty
mv: rename alfred-bundler-aries/wrappers to /Users/eibrahim/Library/Application Support/Alfred 2/Workflow Data/alfred.bundler-aries/wrappers: Directory not empty
[2017-08-29 12:34:58][ERROR: action.script] mv: rename alfred-bundler-aries/includes to /Users/eibrahim/Library/Application Support/Alfred 2/Workflow Data/alfred.bundler-aries/includes: Directory not empty
mv: rename alfred-bundler-aries/meta to /Users/eibrahim/Library/Application Support/Alfred 2/Workflow Data/alfred.bundler-aries/meta: Directory not empty
mv: rename alfred-bundler-aries/wrappers to /Users/eibrahim/Library/Application Support/Alfred 2/Workflow Data/alfred.bundler-aries/wrappers: Directory not empty

 

Share this post


Link to post

here is another one https://github.com/willfarrell/alfred-github-workflow gives the error:

Starting debug for 'Github (v1.7)'

[2017-08-29 14:24:01][STDERR: input.scriptfilter] 2017-08-29 14:24:01.245 defaults[27769:19874971] 
The domain/default pair of (/Users/eibrahim/Library/Application Support/Alfred 2/Workflow Data/com.farrell.github.alfredworkflow/settings.plist, github.proxy) does not exist

Do you see the reference to Alfred 2 above?

Share this post


Link to post
1 minute ago, eibrahim said:

Do you see the reference to Alfred 2 above?

 

@Vero already told you how to fix that.

 

If you create the folder /Users/eibrahim/Library/Application Support/Alfred 2/Workflow Data, many old workflows will still work. Alfred itself doesn't care where workflows keep their data. The problem is that a lot of workflows expect the above directory to already exist.

 

It might also be a good idea to install this workflow. It will fix a lot of older workflows that don't work properly on Sierra.

 

Ultimately, a lot of workflows were written when Alfred 2 was young and never updated again, so they require a small amount of work to get them functioning under Alfred 3.

 

For any workflows that aren't fixed by doing one or both of the above, your best bet is to seek out their GitHub repo or forum thread for information/help. The chances of the author seeing this thread are low.

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...