Jump to content
gokubi

Unable to find bookmarks with new bookmarks feature [Fixed 3.6 b893 pre-release]

Recommended Posts

* What you were doing when the issue happened
I turned on the new Web Bookmarks search feature and I can't get chrome bookmarks to show up in results. Safari bookmarks are returned
 
* Whether you were able to replicate it a second time by performing the same action
Yes. I have disabled and re-enabled, reloaded the cache multiple times, rebooted. Still get same result
 
* Include any screenshots that might help us
* Include the Alfred version & build number you are using
3.5.875
* Include your OS X version
High Sierra 10.13, Chrome 61.0.3163.100 (Official Build) (64-bit)

Alfred_Preferences.png

Share this post


Link to post
Share on other sites

Working now. Perhaps indexing takes quite a bit longer than expected?

 

[update: i was mistaken. still not working for chrome]

Edited by gokubi

Share this post


Link to post
Share on other sites

@gokubi Are you using the default Chrome profile or a secondary/renamed profile? As this is a brand new feature, Alfred looks for the Default profile in Chrome :) 

 

Cheers,

Vero

Share this post


Link to post
Share on other sites

@gokubi Take a look in this path: ~/Library/Application Support/Google/Chrome/

 

Is there a subfolder called "Default"? This should contain a file called "Bookmarks", which contains your formatted bookmarks.

 

Cheers,
Vero

Share this post


Link to post
Share on other sites

When you create a new profile in Chrome, the Default profile (and folder) goes away, so I solved it this way:

 

  1. Create a new folder "Default" in ~/Library/Application Support/Google/Chrome/
  2. Open Terminal
  3. Create a symlink called Bookmarks in the Default folder that points to the Bookmark file in your current Profile folder: ln -s ~/Library/Application\ Support/Google/Chrome/yourProfileDirectory/Bookmarks ~/Library/Application\ Support/Google/Chrome/Default/
  4. Go to Alfred Preferences and enable Web Bookmarks for Chrome
  5. Voila!

Thanks for this great feature! I've been wanting to search bookmarks in Chrome since I installed Alfred in 2011!

Share this post


Link to post
Share on other sites

Nice instructions, thanks! :)

 

In a future update, Alfred will get better non-default profile support for Chrome bookmarks, which will mean you shouldn't have to faf like this!

 

Cheers,

Andrew

Share this post


Link to post
Share on other sites
13 hours ago, gokubi said:

When you create a new profile in Chrome, the Default profile (and folder) goes away, so I solved it this way

 

I have multiple profiles, and one is still in the "Default" folder.

Share this post


Link to post
Share on other sites

Interesting. My research was a bit contradictory, so that's not totally surprising. I may have deleted the default profile. There seems to be no way to get one back that's in a folder called Default if that changes through rename, or deleting.

Share this post


Link to post
Share on other sites

I think profile folders are easily identified by looking for top-level folders with a file named “Bookmarks” in them.

 

No idea where the actual names of the profiles are stored, though. 

Share this post


Link to post
Share on other sites

The Alfred 3.6 b893 pre-release is now aware of multiple Google Chrome profiles, and you can select which one you'd like to use in Alfred's Web Bookmarks features prefs.

If you have setup any symlinks workarounds etc, it's probably worth backing these changes out now.

 

Cheers,
Andrew

Share this post


Link to post
Share on other sites

×
×
  • Create New...