Jump to content

Alfred file search: sort by date?


Recommended Posts

I have noticed over the past few updates that when searching for a file using Alfred file search, the results now display alphabetically instead of having the most recent file first.  I think this might be related to the line in the most recent release notes: "Fix alphabetically sorting files in Alfred's File System navigation with APFS".


Is there a way to revert back to the previous behaviour of most recent files displayed first?  I liked this much better!  My apologies if this issue has already been raised.

Link to comment

@cstsoi That fix relates to file system navigation browsing and filtering, not Alfred's default file search... Alfred's file search should be sorted and organised based on your usage. If you've recently updated to macOS High Sierra, you may find that macOS has reindexed itself and the results aren't showing in the most used order until you've had a chance to re-teach it.


If you create a new text file on your desktop (named something similar to an already existing file), then search for it, does it show at the top?




Link to comment
On 10/31/2017 at 1:23 PM, Andrew said:

If you create a new text file on your desktop (named something similar to an already existing file), then search for it, does it show at the top?


Hello, I am experiencing the same behavior as @cstsoi and performing the test quoted above does not show recent files saved to the desktop in the file search results. I have also recently tried Alfred Preferences > Advanced > Rebuild macOS Metadata to no avail.


Do you have any other recommendations?


Thank you!


Link to comment
10 hours ago, Andrew said:

Is spotlight finding the new file you created?


Have you tried creating a new user account?

Yes, Spotlight finds it.

Yes, I just created a new user account on the Mac and Alfred still doesn't surface up the most recent files.

I'd also add that my files are stored on Dropbox. However, I created copies of test files onto iCloud Drive (under Documents) as well as onto a local directory on my hard drive. Alfred doesn't surface up the latest file from either of 3 sources. :-/ 

Edited by johnnyxhuynh
Link to comment

@Vero Does the Metadata Tool allow you to see the actual contents of a file? I'm concerned about confidentiality.


Also, please note, that Alfred does not show the most recent file at the top of the search results when I type the first few characters of the filename. If I make my search more specific down to the very specific filename, it WILL eventually turn up the file.


See attached examples of the search results I get when I search for "time", "time tracker", and "time tracker 201711" in an attempt to get the most recent version of this file that I update almost on a daily basis. At some point in the past — at least several months — I was able to simply type "time" and get the latest file I can open by pressing return on my keyboard.


Thanks for your assistance,


Screen Shot 2017-11-11 at 6.19.27 AM.png

Screen Shot 2017-11-11 at 6.19.31 AM.png

Screen Shot 2017-11-11 at 6.19.35 AM.png

Link to comment
9 hours ago, johnnyxhuynh said:

Is pressing the return key on my keyboard "actioning the result"?


Yes. Alfred remembers what you action for each query, and moves that result to the top. Of course, it doesn't work if you action several different items for the same query.

Link to comment
  • 1 month later...

Just an update that this problem seems to have fixed itself on my computer.  Not sure if it is a 10.13.2 thing, or if as you said the OS needed to finish indexing (though when I had first noticed the problem, it had been weeks since the installation of High Sierra).

Link to comment
  • 2 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...