Jump to content
s95hc8

Alfred result sort order for search terms

Recommended Posts

Since a few weeks (I believe after updating Alfred) I have a major issue with searching with Alfred.

 

In the past Alfred used to learn my search patterns so after using it for a while it often was enough to simply type the first one or two letters of an item for Alfred to list search results in most used order.

 

Items I would search and use a lot would always be at the very top of the list.

 

This feature is broken for me and makes the Alfred search pretty much useless to me now :-(

 

Example:

 

I do download regularly Youtube videos to watch later when on the road and not having a internet connection.

For this I use a Alfred Workflow "DownVid".

To download a Youtube video I would simply:

- copy the web URL to the clipboard

- invoke Alfred

- type "DV" (often just typing "D" would have sufficed)

 

… and Alfred would list search results

 

As I would use this workflow invoked by typing "D" or "DV" much more often then any other search starting with the letter D, Alfred would place the DownVid workflow right at the very top of the list, so I only would have to hit "ENTER" to start the workflow.

 

Since the search is broken, this workflow is listed way down a list of to me completely useless search results.

Among them is the "iDVD.app" or the "DVDPlayer.app" which I both never, ever even once have searched for or opened :-(

 

I have scoured the Alfred preferences, have reset Alfred, have deleted the Alfred cache, have repaired permissions, have rebuilt spotlight indexes (using Onyx), … all to no avail.

At current Alfred is useless to me as every search I attempt takes so much longer time and I keep making mistakes, accidentally selecting items I do not want.

 

Please help (I hope it is just one single silly setting I am missing)!

Share this post


Link to post

@s95hc8 Welcome to the forum. It's likely to be something quite simple, so can I clarify a few things based on what you said to help me work out what's happening?

 

Does Alfred's Knowledge work as expected? To test this, type "s" and choose an app (not a workflow) other than your current top result and launch that second result a few times from Alfred. Has Alfred moved that item to the top and learned that's your preferred result for "s"? If not, then permissions are broken and is likely the source of your issue. This can happen when upgrading macOS, so if you've recently updated to High Sierra, that may be when the issue started.

 

You say you've repaired permissions, so could you let me know how you did this? These are the steps we recommend:

https://www.alfredapp.com/help/troubleshooting/preferences/

 

If Alfred's Knowledge is working normally, let me know and I'll suggest next steps.

 

Cheers,
Vero

Share this post


Link to post

Hey Vero,

 

Thanks for your help!

I did what you suggested.

 

I always repair permissions on a regular basis using Onyx (among other regulars maintenance and service).

 

Just to be save, I redid the permission repair today again and then tried your suggestion of "re-sorting" the hierarchy of search results using the search for a regular item.

 

It was successful, so it seems that the underlying learning of search behavior does work as designed - yay!

 

I tried to do the same with the workflow item I was using and it did not work unfortunately :-(

 

iDVD.app and DVDplayer.app still show up ahead of the DownloadVid workflow.

 

Do you have any further suggestions?

Share this post


Link to post

@s95hc8 I suggest you try stopping using Onyx regularly for a little while to see if that helps improve things. It might be that you're accidentally cleaning out necessary caches for macOS (both Spotlight, Finder and Alfred) to operate optimally.

 

Also, if it's specifically this one workflow you are having an issue with, there is a chance it's missing certain things Alfred needs to provide sorting (i.e. result UIDs). Are things like web searches sorting to the top after you've used them a few times?

 

Andrew

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×