Jump to content
jcwacky

1Password Feature Stopped Working

Recommended Posts

 

For some reason Alfread's 1Password feature has stopped working for me. 

 

 

In Alfred Preferences > Features > 1Password it says "Unable to find 1Password Data".

 

If I click AdvancedDiscover Automatically is ticked and it's looking in /Users/james/Library/Caches/Metadata/1Password

 

However, the correct location of my 1Password vault is /Users/james/Dropbox/1Password/1Password.agilekeychain

 

Entering this path instead (or dragging and dropping the file into the field), doesn't resolve it, and it still says "Unable to find 1Password Data" .

 

If I delete /Users/james/Library/Caches/Metadata/1Password and try ticking Discover Automatically again it just says "Unable to find suitable 1Password data path"

 

In 1Password Preferences, I've verified that Enable 3rd party app integrations is ticked and I've tried toggling it off then on again.

 

I'm using 1Password 6.8.4 and Alfred 3.5.1 on macOS 10.13.1

 

The only thing I can remember doing since it was last working was upgrading to 1Passwords hosted account plan, and then reverting back to my locally hosted vault in Dropbox.

 

Any further suggestions?

Share this post


Link to post
7 hours ago, jcwacky said:

the correct location of my 1Password vault

 

Where your vault is stored isn't important: those aren't the data Alfred uses.

 

The path Alfred was using (~/Library/Caches/Metadata/1Password) is correct. It sounds like something has gone wrong on 1Password's end after you switched to hosted and back again.

 

Try turning "Enable 3rd party app integrations" on and off again, quitting 1Password in between. Perhaps create a new item in 1Password to try and get it moving again, and see if it re-creates the above directory.

 

Edited by deanishe

Share this post


Link to post

Thanks @deanishe . Turns out a combination of toggling Enable 3rd party app integrations off/on in 1Password plus some toggling in Alfred eventually resolved this. My confusion with thinking ~/Library/Caches... was incorrect could have also affected things, so thanks for clarifying that.

Share this post


Link to post

I recently came across this exact same error after running a CleanMyMac scan, which deleted all meta data for most of my apps, including 1Password.

I've done this many times before with no issue. But I also recently moved my 1Password Vaults from Dropbox sync to having a 1Password Family Account (meaning I've removed my local vaults).

This meant, no matter what you do (restart 1Password, restart mac) the meta data files that are needed to tie Alfred and 1Password together are not recreated!

 

The Fix
Go to 1Password settings > Advanced > Check the box for "Allow create of vaults outside of 1Password accounts"
This does then create the necessary meta data and thus ties Alfred back to 1Password, you can unchecked this box again after this process and Alfred will still work with 1Password

 

Hope that helps someone if you have a similar issue!

Share this post


Link to post
On 7/20/2018 at 5:26 AM, robgill said:

The Fix
Go to 1Password settings > Advanced > Check the box for "Allow create of vaults outside of 1Password accounts"
This does then create the necessary meta data and thus ties Alfred back to 1Password, you can unchecked this box again after this process and Alfred will still work with 1Password

 

Hope that helps someone if you have a similar issue!

 

This worked for me in a very similar situation. Used AppCleaner to remove 1Password after having switched to a 1password.com account. No combination of toggling worked until I enabled "Allow create of vaults outside of 1Password accounts" AND created a new item in the local vault. Then Alfred picked it up and I was able to uncheck "Allow create of vaults outside of 1Password accounts" and delete the local vault. All good. Thanks for circling back with your fix!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...