Jump to content

Google Calendar View


Recommended Posts

1 hour ago, dillonplunkett said:

it looks like the latest .alfredworkflow release available on github predates those additions

 

That is correct. I haven't made a release with the new feature yet. I'm still ironing out bugs and want to add another feature or two before the next release.

Link to comment
  • 4 weeks later...
  • 7 months later...

@deanishe I am having trouble with gcal config. I am running Alfred v3 with gcal workflow release v0.3.0

 

I get an error as displayed below when gcal plug calls the workflow associated with gcalconf workflow:login

 

The browser shows,

 

401. That’s an error.

Error: deleted_client

The OAuth client was deleted.

Request Details
access_type=offline
client_id=xxxyyyzzz.apps.googleusercontent.com
prompt=consent
redirect_uri=http://localhost:61432
response_type=code
scope=https://www.googleapis.com/auth/calendar https://www.googleapis.com/auth/userinfo.email
state=xxxyyyzzz

 

Is that localhost server supposed to be stood up before we make the OAuth API call?

 

Please let me know if you can help. Thank you.

Edited by jerry
Link to comment
  • 3 months later...
  • 2 months later...
  • 4 weeks later...
  • 1 month later...
  • 4 months later...

I have version 0.5.1 and am running into issues with the authentication.  When I click on the No Account Configured it walks me through the authorization and returns "OK" but when I attempt to run the workflow again I am right back at the same place.

 

Any thoughts on where to go from here?

 

 

image.thumb.png.997804464e63644b877567cda2c8a732.png

Link to comment
  • 4 months later...
On 7/17/2021 at 12:54 PM, jn08 said:

Is there any way to show the time of events in the upcoming events?

 

The workflow does show the start and end time of events (it would be pretty silly if it didn’t). You’ve probably found a bug. Please look at the log file (enter gdate workflow:log into Alfred).

 

Link to comment

Ah, well that does make more sense. Here's a slightly edited log (to remove identifying info). Any ideas? Something to do with the missing info.plist file?

 

20:39:45 ---- Google Calendar View/0.5.1 (AwGo/0.20.2) ----
20:39:45 Opening log file…
20:39:45 Sent 1 result(s) to Alfred
20:39:45 ------------------ 167.633583ms ------------------
20:39:52 ---- Google Calendar View/0.5.1 (AwGo/0.20.2) ----
20:39:52 [main] query="", startTime=2021-07-19 20:39:52.32482 +1000 AEST, endTime=2021-07-20 20:39:52.32482 +1000 AEST
20:39:52 [account] loaded &{Name:email@gmail.com Email:email@gmail.com AvatarURL:https://lh3.googleusercontent.com/a/default-user=s96-c ReadWrite:true Calendars:[0xc0003aa280 0xc0003aa2d0 0xc0003aa320 0xc0003aa370 0xc0003aa3c0 0xc0003aa410 0xc0003aa4b0 0xc0003aa500 0xc0003aa550 0xc0003aa5a0 0xc0003aa5f0 0xc0003aa640 0xc0003aa690 0xc0003aa6e0 0xc0003aa730 0xc0003aa780 0xc0003aa7d0 0xc0003aa820 0xc0003aa870 0xc0003aa8c0 0xc0003aa910 0xc0003aa960 0xc0003aa9b0 0xc0003aaa00 0xc0003aaa50 0xc0003aaaa0 0xc0003aaaf0 0xc0003aab40 0xc0003aab90 0xc0003aabe0 0xc0003aac30 0xc0003aac80 0xc0003aacd0 0xc0003aad20 0xc0003aad70 0xc0003aadc0 0xc0003aae10 0xc0003aae60] Token:0xc000390ea0 auth:<nil>}
20:39:52 [main] 38 calendar(s) in 1 account(s)
20:39:52 4 active calendar(s)
20:39:52 Quick Father's Day Catch Up
20:39:52 Stand-up | Cross departmental alignment
20:39:52 Stand-up | Cross departmental alignment
20:39:52 Books Team Meeting
20:39:52 Books Team Meeting
20:39:52 Cass / Joel 1:1
20:39:52 BIP Meeting
20:39:52 
20:39:52 Weekly Sales & Ops Meeting
20:39:52 Weekly Sales & Ops Meeting
20:39:52 Sales & Operations Meeting PM
20:39:52 Sales & Operations Meeting PM
20:39:52 Evening Stand-up
20:39:52 [URGENT] Customer Promise V Capacity
...[etc]

20:39:52 85 event(s) for 2021-07-19
20:39:52 Sent 90 result(s) to Alfred
20:39:52 ------------------ 19.029375ms -------------------
20:39:52 ---- Google Calendar View/0.5.1 (AwGo/0.20.2) ----
20:39:52 [main] query="", startTime=2021-07-19 20:39:52.352406 +1000 AEST, endTime=2021-07-20 20:39:52.352406 +1000 AEST
20:39:52 [account] loaded &{Name:email@gmail.com Email:email@gmail.com AvatarURL:https://lh3.googleusercontent.com/a/default-user=s96-c ReadWrite:true Calendars:[0xc0003b4230 0xc0003b4280 0xc0003b42d0 0xc0003b4320 0xc0003b4370 0xc0003b43c0 0xc0003b4460 0xc0003b44b0 0xc0003b4500 0xc0003b4550 0xc0003b45a0 0xc0003b45f0 0xc0003b4640 0xc0003b4690 0xc0003b46e0 0xc0003b4730 0xc0003b4780 0xc0003b47d0 0xc0003b4820 0xc0003b4870 0xc0003b48c0 0xc0003b4910 0xc0003b4960 0xc0003b49b0 0xc0003b4a00 0xc0003b4a50 0xc0003b4aa0 0xc0003b4af0 0xc0003b4b40 0xc0003b4b90 0xc0003b4be0 0xc0003b4c30 0xc0003b4c80 0xc0003b4cd0 0xc0003b4d20 0xc0003b4d70 0xc0003b4dc0 0xc0003b4e10] Token:0xc00039aea0 auth:<nil>}
20:39:52 [preview] starting preview server on localhost:61433 ...
20:39:52 [warning] info.plist not found. Guessed: /Users/Joel/Library/Application Support/Alfred/Alfred.alfredpreferences/workflows/user.workflow.D16D5E9D-1752-43FF-A087-C1BBC3B39810
20:40:22 [preview] 30s since last request
 

Link to comment
4 hours ago, jn08 said:

Something to do with the missing info.plist file?

 

Maybe. It seems to be running in the wrong directory. Re-installing the workflow would be a good idea.

 

Also, open Alfred's debugger next time you run it.

Link to comment

I have tried reinstalling a few times, though I'm not sure it's properly uninstalling each time. The accounts and account preferences seem to remain when I do uninstall it. Is there a location on MacOS that stores pref files or something that needs to be deleted along with removing the workflow from Alfred?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...