Jump to content

Recommended Posts

Hi, have a file action to convert gifs to mp4 using ffmpeg:

 

ffmpeg -f gif -i {query} -pix_fmt yuv420p -c:v libx264 -movflags +faststart -filter:v crop='floor(in_w/2)*2:floor(in_h/2)*2' ~/Desktop/converted_file.mp4

This works perfectly with the terminal command but I want it to run it as a script so it doesn't opens a terminal window.  Do I have to change anything? The way it it's not working.

 

Thanks in advance for your help!

Share this post


Link to post

You probably need to use the full path to ffmpeg, e.g. /usr/local/bin/ffmpeg, instead of just ffmpeg.

Share this post


Link to post
31 minutes ago, deanishe said:

You probably need to use the full path to ffmpeg, e.g. /usr/local/bin/ffmpeg, instead of just ffmpeg.

 

Thats it! I tried with "/usr/local/bin/ffmpeg" before but didn't worked. Turns out my path is "/usr/local/Cellar/ffmpeg/3.4/bin/ffmpeg".

 

Thank you!

Share this post


Link to post
22 hours ago, deanishe said:

Sounds like you should run brew link ffmpeg to put it on your PATH.

 

I ran "brew cleanup" to remove older versions and then "brew link ffmpeg" and now "/usr/local/bin/ffmpeg" works.

 

Thank you so much deanishe!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×