Jump to content

Recommended Posts

Hi, have a file action to convert gifs to mp4 using ffmpeg:

 

ffmpeg -f gif -i {query} -pix_fmt yuv420p -c:v libx264 -movflags +faststart -filter:v crop='floor(in_w/2)*2:floor(in_h/2)*2' ~/Desktop/converted_file.mp4

This works perfectly with the terminal command but I want it to run it as a script so it doesn't opens a terminal window.  Do I have to change anything? The way it it's not working.

 

Thanks in advance for your help!

Share this post


Link to post
31 minutes ago, deanishe said:

You probably need to use the full path to ffmpeg, e.g. /usr/local/bin/ffmpeg, instead of just ffmpeg.

 

Thats it! I tried with "/usr/local/bin/ffmpeg" before but didn't worked. Turns out my path is "/usr/local/Cellar/ffmpeg/3.4/bin/ffmpeg".

 

Thank you!

Share this post


Link to post
22 hours ago, deanishe said:

Sounds like you should run brew link ffmpeg to put it on your PATH.

 

I ran "brew cleanup" to remove older versions and then "brew link ffmpeg" and now "/usr/local/bin/ffmpeg" works.

 

Thank you so much deanishe!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...