Jump to content

Is the 3.6 pre-release stable enough for everyday use?


Recommended Posts

As of my experience with Alfred i always use the pre released version and never had any issues.

The only time I had problems was at the time i was testing the Alfred 3 beta. But that update was just for 

those who wanted to help testing aside of the pre release versions of Alfred 2.

 

I am currently on the latest pre Release of Alfred and the search works. No know issues from my side and

I use Alfred daily at work and privat :)

 

Cheers,

 

Frozen

Link to post

I’ve been on pre-release versions since Alfred 2 (yes, 2), and never had major issues. Maybe I’ve had a hang (had to force quit) or a crash (had to reopen), but I can’t even say with certainty if I was on a pre-release at the time or if it was Alfred’s problem and not a system one. But I’ve never experienced anything more serious than that. Though it is weird when I have to reopen Alfred, because my brain is so used to using Alfred to start everything, I always freeze for a moment to think how to reopen it (and my first move is to usually try — and fail — to invoke Alfred’s shortcut to open /Applications).

Edited by vitor
Link to post

IIRC, there has only ever been one (fairly minor) issue with a pre-release that was backed out. Basically, the pre-release is always a better version of Alfred. They aren't betas.

 

On 26/01/2018 at 11:41 AM, vitor said:

Though it is weird when I have to reopen Alfred, because my brain is so used to using Alfred to start everything, I always freeze for a moment to think how to reopen it

 

So much. Every time I relaunch Alfred, I spend a couple of seconds in existential crisis wondering how the hell to run an app without it…

 

Even though I can think of 3 alternative methods off the top of my head.

Link to post
On 1/26/2018 at 11:41 AM, vitor said:

Though it is weird when I have to reopen Alfred, because my brain is so used to using Alfred to start everything, I always freeze for a moment to think how to reopen it (and my first move is to usually try — and fail — to invoke Alfred’s shortcut to open /Applications).

 

I have the same issue haha, sitting there for a moment and be like ummmm ummm oh yeah lemme use spotlight.....Alfred is back and there is a relieve xD like uff now the chain is released again. "you dont know what you got until its gone"

 

That now actually reminds me that there is a bug that happened a few days ago once again oO Whenever i am browsing through a slow external drive or a server

Alfred sometimes idk why tends to freeze. That’s actually all i have an issue with.

Edited by FroZen_X
Link to post
1 hour ago, FroZen_X said:

sitting there for a moment and be like ummmm ummm

 

On a not-very-related noted, I managed to fat finger my menubar today and turn Bluetooth off, so my trackpad no longer worked. It took me a good few minutes to figure out how to turn it back on.

 

No problem, I thought, I'll just Google the shell command with Alfred. Of course, I couldn't click on any of the links…

 

Eventually, I remembered there's a Bluetooth Preference Pane, and I could TAB to the Turn Bluetooth On button.

 

But for a few minutes, I was sweating bullets.

Link to post
2 hours ago, FroZen_X said:

lemme use spotlight

 

I can never do that because I hide its icon with Bartender and disable its shortcut (graphic design software tends to use ⌘␣ to zoom and I use that extensively).

 

20 minutes ago, deanishe said:

I'll just Google the shell command with Alfred. Of course, I couldn't click on any of the links…

 

You can ⇥ through google results.

Link to post
13 minutes ago, vitor said:

You can ⇥ through google results.

 

Didn't know that. Just tried it, and you can tab through some of them. In any case, when I said "Google", I actually used DuckDuckGo, which doesn't let you tab through results :( 

 

That's when I remembered the Bluetooth Pref Pane. If I'd been stuck searching the web for a solution, I would have fired up Chrome, as I have Vimium installed in that. Or just used my phone to search.

Link to post
54 minutes ago, deanishe said:

I actually used DuckDuckGo, which doesn't let you tab through results :( 

 

You can, but it takes a while. I searched for “Alfred” and had to press ⇥ 14 times until I got to the first result. After that I had to ⇥ 3 times to get to the next search result. It is a pain, but in a pinch it would do. The visual feedback is also very subtle, so it’s best to rely on the small indicator Chrome has for the link you’re hovering (the one on the bottom left).

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...