Jump to content

Multiple upgrade issues, mainly Alfred preferences crash and won't load


Recommended Posts


I've been using Alfred for forever and practically can't work without it.


I upgraded today to v2 and had a very bad upgrade experience - Migration did not restart Alfred nor shut down Alfred v1, the features tab did not load and currently I'm stuck with a non functioning Alfred and the preferences window never loads and always crash.


What I did - 


- I downloaded Alfred Alfred_2.0.1_173 (and upgraded to the Mega Supporter license), Installed it, pressed the Migrate button but Alfred did not restart.

- Restarted manually, quitted Alfred v1 manually, Alfred v2 loaded but I got an empty features (Can't remember if thats the right tab name) tab in the preferences.

I thought maybe the migrate went wrong and migrated again, same result.


I then went to look through the Advanced tab thinking I might find a solution there, and while at it turned on the sync, creating an "Alfred" folder in my dropbox and moving my preferences there.

Again, Alfred restart did not work and I restarted manually,


Since then I can't open the preferences and Alfred itself only opens the text window but it doesn't function.


Thinking it's the sync that killed Alfred I tried to delete all my alfred.alfredpreferences files, tried to delete com.runningwithcrayons.Alfred-2 and com.runningwithcrayons.Alfred-2.plist files and reinstall Alfred... nothing works.


I'm Alfredless.


I stopped and went here because I don't want to delete any Alfred v1 file accidentally and lose All my presets.


Also, I found the crash report logs but I don't know how to analyse them (can't find an 'upload file' button here so I've put the latest one in my dropbox) - https://dl.dropbox.com/u/1119485/Alfred%20Preferences_2013-03-18-000225_Toms-MacBook-Air.crash


Please help.

Link to comment
Share on other sites

Hi there,


The crash very much looks like a corruption possibly somewhere in Alfred 2's download, so I'm sure we'll get you up and running soon! If you could perform the following steps:


1. Could you fully reset Alfred using this guide:



2. Then open Disk Utility.app and run a repair permissions on your main drive.


3. After this, re-download Alfred from:



4. Just in case Archive utility is playing up in OS X (if Safari automatically unzipped, delete the unzipped one), manually unzip this by opening Terminal and pasting in:

cd ~/Downloads

unzip Alfred_2.0.1_173.zip


5. Copy Alfred 2.app from ~/Downloads to /Applications


Run Alfred 2 and let me know how you get on. And don't worry, Alfred 2 doesn't delete or write to any of Alfred 1's settings, so they will remain safe :)




Link to comment
Share on other sites


I've been using Alfred for forever and practically can't work without it.

Please help.


Another quick thought, this weirdness and prefs crashing could also be a side effect of moving the Alfred 2.app bundle manually after Alfred 2.app is running.


Either way, reinstall as described above and let me know :)

Link to comment
Share on other sites

Worked like a charm :)



btw - I originally extracted the archive with iUnarchive if you wish to investigate whether it fails to unzip Alfred


Perfect! Very interesting indeed - Alfred is zipped with ditto so I wonder if iUnarchive just isn't fully compatible with this?

Link to comment
Share on other sites

Maybe it fails to rewrite the symbolic links? Anyway, if you have a test scenario you want me to try just say the word.


I think that is likely as all the internal frameworks have all sorts of symbolic links in them. As Alfred is unzipping fine with unzip and Archive Utility (and Safari), it's probably best if you report this to iUnarchive as there may be other corrupted zips you are unzipping which don't manifest in a crash like Alfred saw.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...