Jump to content

Shell scripts work outside of Alfred, but not in workflows

Recommended Posts



This shell script works if I run sh ip.sh or env -i ip.sh, but not when I paste it into Alfred as part of a workflow. I get the following error:



[2018-03-22 02:09:11][utility.filter] Processing output of 'action.script' with arg 'pi1'

[2018-03-22 02:09:12][ERROR: action.script



export PATH=/usr/local/bin:$PATH

export http_proxy='proxy:pass@'
/usr/bin/curl 'ipinfo.io/ip'



Similar problem, this works when I run it from terminal


ssh user@ip -p 1234 -T<<'ENDSSH'
sudo sh /etc/blablabla/shell.sh

In Alfred it's stuck at Processing output of 'action.script' and nothing happens. 

Tested to run them as external script and bash scripts in alfred.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...