Jump to content
charlie-brise

1Password 7.0 "open and fill" not working in Chrome and Firefox [1Password Fixed]

Recommended Posts

It almost works with 1Password 7.0.4 which fixes the issue with Open and Fill, but there is still a bug in 1Password which I've fed back to them.

 

Shouldn't be long now!

 

Cheers,

Andrew

Share this post


Link to post
Share on other sites

I've just done a new Alfred pre-release which mostly works aside from the bug I spotted with Google Chrome, which is when you have Chrome launched but no windows open, 1Password won't open the window to the specified URL. Open and Fill should work fine other than this.

Share this post


Link to post
Share on other sites

@HRD this will need to be fixed by 1Password - I've already emailed them about it. The latest release of Alfred now correctly calls the new 1Password 7 URL scheme to Open and Fill. After this point, Alfred has no control over what happens.

 

I'm sure they'll have this fixed up quickly! :) 

 

Cheers,

Andrew

Share this post


Link to post
Share on other sites

So as far as I can tell...

 

Alfred's 1Password 7 integration works as long as 1Password is already unlocked otherwise nothing happens.

 

If they are using Google Chrome which is launched but has no windows open, using the 1Password URL scheme yields nothing.

 

I've fed this back to 1Password, so hopefully we can see a fix for this asap! :) 

 

Note, I've done Alfred 3 b918 pre-release today which I'm hoping will be compatible with any fixes 1Password will make to resolve this!

 

Cheers,

Andrew

Share this post


Link to post
Share on other sites

Yes, you're right. When 1P is locked/closed, nothing happens, not even Safari starts. When 1P is unlocked, Safari starts, but autofill does not work correctly, only username is filled.

Share this post


Link to post
Share on other sites

1Password is well aware of the issue. See the latest here . It would appear that a fix is on its way soon.

  • brise

Share this post


Link to post
Share on other sites
Posted (edited)

Just updated alfred today. Autofilling now is working for me in Chrome, when 1p is unlocked.

 

Also, i've noticed that i can't open my secure notes / credit cards using alfred now. If i type "1p My Visa" it just brings 1password main window...

It's just work with Logins, but not with Credit Cards / Notes.

Edited by Alexander

Share this post


Link to post
Share on other sites
10 hours ago, Alexander said:

@Andrew are you there, mate? Can you check Notes, please.

 

I don't know what you expect Andrew to do about it. From your description, Alfred is clearly successfully calling 1Password. By all appearances, it's 1Password that's dropping the ball. You should probably ask on the AgileBits forum.

Share this post


Link to post
Share on other sites

×