Jump to content
Sign in to follow this  
barrettj

PathFinder support is not working as intended

Recommended Posts

 

This behaviour is actually controlled by PathFinder which modifies Alfred's settings files to intercept the system calls for opening and revealing in Finder. Other users have reported quitting Alfred, then unticking and reticking PathFinder's option to be the default file manager, then rebooting fixes the issue :)

Share this post


Link to post
Share on other sites

Nothing I had done with toggling the setting in PathFinder and restarting worked (I literally spent over 2 hours trying different combinations of toggling the setting, restarting apps, and restarting my computer).

 

But based on your statement about modifying the setting file, I looked into it and I found something which does work:

 

Quit Alfred 2

Open ~/Library/Preferences/com.runningwithcrayons.Alfred-2.plist (this file is a binary property list, so you'll need a plist viewer - I'm using Xcode)

Under Root (where everything is), add a key called NSFileViewer of type String with the value com.cocoatech.PathFinder

Repeat the process for ~/Library/Preferences/com.runningwithcrayons.Alfred-Preferences.plist - just to be sure

Restart Alfred 2 and everything will be working as you expect.
Edited by barrettj

Share this post


Link to post
Share on other sites

~/Library/Preferences/com.runningwithcrayons.Alfred-2.plist is the one you will likely want to add NSFileViewer into as this is Alfred rather than the preferences... but adding to both wouldn't hurt as the prefs has "Reveal in Finder" things too.

 

Where did you find that statement? as it will likely need to be changed.

 

Cheers,

Andrew

Share this post


Link to post
Share on other sites

Ahh, I had added it to both, but the "Alfred-2.plist" one was largely empty and the ".Alfred-Preferences.plist" had a lot more in it.

 

I didn't find it anywhere, I just spent a long time figuring out what the checkbox in PathFinder was supposed to be doing (it was setting the NSFileViewer in the plist for the dock) and when you said it was supposed to be modifying the preference file for Alfred I just tried adding that preference there as well.

Share this post


Link to post
Share on other sites

Ahh, I had added it to both, but the "Alfred-2.plist" one was largely empty and the ".Alfred-Preferences.plist" had a lot more in it.

 

I didn't find it anywhere, I just spent a long time figuring out what the checkbox in PathFinder was supposed to be doing (it was setting the NSFileViewer in the plist for the dock) and when you said it was supposed to be modifying the preference file for Alfred I just tried adding that preference there as well.

 

Does it seem to be working now for you then?

Share this post


Link to post
Share on other sites

Yep, after adding that key to both the .plist files and restarting Alfred 2 it's consistently opening things in PathFinder instead of Finder.

 

Great! It might be worth raising this one with PathFinder as it's PathFinder which should be adding that key to Alfred-2.plist when you untick and retick the option, and it's obviously not doing! :)

Share this post


Link to post
Share on other sites

I have been struggling with a problem with Path Finder for some time with regards to apps not opening it when they attempt to reveal Finder.  I've known for many months that this is likely due to a problem with NSFileViewer from my beta days of Mountain Lion and some kind of oddity in my preferences.  Is anyone aware of a way to brute force modify all instances of NSFileViewer within one's preferences to seek and destroy instances of Finder being associated with Path Finder?


Edited by ylluminate

Share this post


Link to post
Share on other sites

I have added NSFileViewer of type String with the value com.cocoatech.PathFinder to both plist files.  Now a "find" command does not Reveal in Finder or Path Finder but just does nothing.  I deleted and rebuilt the Finder plist file which didn't help.  I also uncheck and recheck Path Finder's "Use as default browser" (with Alfred 2 closed) which also didn't help.  Any other suggestions to get Alfred 2 working with Path Finder 6.1.5?

Edited by MacMichael

Share this post


Link to post
Share on other sites

 

Nothing I had done with toggling the setting in PathFinder and restarting worked (I literally spent over 2 hours trying different combinations of toggling the setting, restarting apps, and restarting my computer).

 

But based on your statement about modifying the setting file, I looked into it and I found something which does work:

Quit Alfred 2

Open ~/Library/Preferences/com.runningwithcrayons.Alfred-2.plist (this file is a binary property list, so you'll need a plist viewer - I'm using Xcode)

Under Root (where everything is), add a key called NSFileViewer of type String with the value com.cocoatech.PathFinder

Repeat the process for ~/Library/Preferences/com.runningwithcrayons.Alfred-Preferences.plist - just to be sure

Restart Alfred 2 and everything will be working as you expect.

 

I just wanna tell that suddenly I have started to suffer this post problem, but doing exactly what you said now it works again :)

 

thanks!

Share this post


Link to post
Share on other sites

I am using pathfinder. When I do "open in finder" I don't want to open the file with the default application. I want to go to the location of that file inside pathfinder.

 

Anyone know how to fix this?

Share this post


Link to post
Share on other sites

I am using pathfinder. When I do "open in finder" I don't want to open the file with the default application. I want to go to the location of that file inside pathfinder.

 

Anyone know how to fix this?

 

Are the solutions above not working for you? This should override the "open in finder" behaviour.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...