Jump to content
Sign in to follow this  
dra

Force Keyboard delays

Recommended Posts

Hello,

I usually use both Japanese and English. So I need to switch Keyboard in changing the language.

I'd like to use Alfred in English always, so Force Keyboard option is very appreciated.

However, this forcing change isn't sometimes completed before typing in Alfred toggle field.

 

Would it be possible to shorten this duration in the feature?

 

Alfred v3.6 [903]

macOS High Sierra 10.13.4 (17E202)

Share this post


Link to post

@dra Alfred requests a keyboard change the instant you use the Alfred hotkey, so has no control over the speed of the language change. In my testing, this has always been pretty instant, so I'm not sure what could be causing a delay for you.

 

One thing you could try is setting the focus mode to "Compatibility" in Alfred's Appearance > Options. This makes Alfred work more like a traditional macOS window, so may change the behaviour.

 

Also, make sure you don't have a conflicting setting in the macOS Keyboard > Input Sources > Automatically switch to a document's input source.

 

Cheers,

Andrew

Share this post


Link to post

Thank you for your advice.

Yes, "Compatibility" function seems to resolve my issue. I confirmed I don't use the automatically switch function on macOS.

I'll see how it goes on afterwards.

 

Best,

Dra

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×