Jump to content

Duplicated fallback search and workflow triggers seem broken [Fixed internally for Future Release]


Bouzmine
 Share

Recommended Posts

I was trying to set up Fallback Search options with some custom options based on the default Fallback Search workflow trigger in the Workflows tab. After creating one workflow trigger, everything was fine, so I created other workflows. When I tried to add those new workflows in the Features tab under Fallbacks, the workflow I had added previously had been replaced by the last one I had created. Moreover, when I tried to add the other ones, no matter which one I clicked, it would add the last workflow created. I tried removing the workflows, rebooting Alfred multiple time, changing the bundle IDs, etc.

 

Am I doing something wrong ? Thanks a lot.

Link to comment
Share on other sites

@Bouzmine Welcome to the forum. :) 

 

Could you please share your workflow(s) or tell us more about them? Just to be clear, each fallback search you want to set up needs to have its own Fallback Search trigger in the preferences. 

 

To add a new Fallback Search object, you can right-click the workflow canvas and choose Trigger > Fallback Search, which you can then attach to the action you want to perform. Do this to create a new one, rather than editing an existing one.

 

If I've misunderstood your issue, please provide more details and we'll be happy to help.

 

Cheers,
Vero

 

Link to comment
Share on other sites

There are three workflows based on the canvas for Fallback Search, I just changed the search url, the title and the bundle ID for each one. What you described is exactly what I did. I added three workflows from the canvas, edited them individually, then tried to add them to my Fallback Search results, put I could only add one; if I tried to click on different ones, it would just add the same over and over. Would you want a video of this behavior? Thank a lot for your time.

Link to comment
Share on other sites

@Bouzmine I can reproduce this and can see what's happening. In duplicating an entire workflow, while the parent UID changes, the fallback item UID is staying the same which is causing the problem when adding fallbacks.

 

To fix this, if you open one of the workflows, select all and cut the contents and re-paste it back in, the items will have new UIDs and will work as expected (note, the fallback icon will disappear because of this).

 

I'll have a think about what can be done to make this work as expected :)

Link to comment
Share on other sites

Thank you for the answer. Your workaround works like a charm. I hope to see a fix for this issue in a future release to prevent other users from being confused by this behaviour.

Edited by Bouzmine
Link to comment
Share on other sites

  • Andrew changed the title to Duplicated fallback search and workflow triggers seem broken [Fixed internally for Future Release]

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...