Jump to content
quasimagyar

Waiting for results...

Recommended Posts

Recently, after a computer crash, my Alfred stopped providing me with search results. When I try for a search, Alfred says it's waiting for results (it also can't find applications).

 

image.thumb.png.28bf569578be6792f5580bff5083c2a6.png

 

When I do a search with spotlight, I get plenty of results. I've tried to rebuild the application cache and the metadata. I've also tried uninstalling and reinstalling the app. Absolutely no idea what else to try. Can anyone help?

Share this post


Link to post

Hi @quasimagyar, welcome to the forum.

 

3 hours ago, quasimagyar said:

I've tried to rebuild the application cache and the metadata.

 

I can't answer your question, I'm afraid, but it's largely pointless to rebuild the macOS metadata if Spotlight is working correctly: Alfred and Spotlight use the same index.

Share this post


Link to post

I had the same problem for weeks and I finally found the problem.

 

In my case it helped to reset the Search Scope in the Default Results screen of the Preferences and then restarting Alfred.

 

In case this doesn't help, try quitting Alfred and move the file ~/Library/Application Support/Alfred 3/Alfred.alfredpreferences out of the way. After this, if Alfred doesn't give the "Waiting for results" message anymore, you know for sure something in your preferences has gone haywire.

 

If you're feeling adventurous, the Alfred.alfredpreferences file is a really a directory ("bundle" in macOS terminology). Try to rename one directory at a time (make sure Alfred isn't running when doing this). This way I found that my Default Results were faulty.

 

Share this post


Link to post

Can confirm this solution, had the same thing happen, unticked and then ticked back the checkbox at the search scope that says "Folders in Home" 

And it now works like it used to!

Thanks @DvZ !

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...