Jump to content

ZotHero — Generate Zotero citations in Alfred


Recommended Posts

Posted (edited)
38 minutes ago, MichaelL said:

I use Scrivener... it should use rtf, isn't it?

 

The workflow puts citations in plaintext, HTML and RTF formats on the clipboard. It's up to the application you're pasting into to choose the appropriate one.

 

What kind of document are you pasting into? I believe both Scrivener and Ulysses support Markdown. If you're pasting into a Markdown document, then it is absolutely correct that & is pasted instead of &.

 

Which citation style are you using?

Edited by deanishe
Link to post

 

32 minutes ago, MichaelL said:

what soul I do differently to still use shift cmd+v?

 

I can't tell you that because ⇧⌘V is not a system shortcut. What that does depends on the application that's responding to that shortcut.

Link to post

I tried to use the Copycite key with Better-Bibtex functionality by setting the COPY_CITEKEY_MOD workflow environment variable to -. But when I copied the citation, it remained in the default format. Am I using it improperly?

Link to post
  • 1 month later...

The keyboard maestro shortcut did not seem to solve pasting as plain text. It keeps pasting as: zotero://select/items/1_9EHZUHXX . Is there another way to just paste a plain reference?

 

Thanks so much for making this awesome workflow!

Link to post
14 hours ago, Jongno said:

The keyboard maestro shortcut did not seem to solve pasting as plain text. It keeps pasting as: zotero://select/items/1_9EHZUHXX . Is there another way to just paste a plain reference?

 

Yeah, you’re kinda doing it wrong. The default action is to open the citation in Zotero, so if you hit ⌘C on a result, it copies the Zotero URL to the clipboard.


You need to use ⌘↩ or ⌥↩ to copy a citation-style or bibliography-style reference respectively to the clipboard. Then you can use the Keyboard Maestro trick to paste the citation without formatting.

 

You may also need to first set a default citation style, which you can do via the workflow’s settings (keyword zotconf) or by pressing ^↩ on a search result to show all citation styles, and then ^↩ again to set a specific style as the default.

 

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...