Jump to content
PAUL R FONTENOT

Remote launch of multiple files does not post notification or play sound

Recommended Posts

I have created the workflow below and the remote trigger is working; the specified file is opened when I tap it on my remote page; but the workflow does not post notification or play sound.  ?

 

Am I missing a  piece to the puzzle?  Are there some action modules that need to be inserted into the workflow for it to post notification and play sound??

 

2104085477_REMOTELAUNCH.jpg.c50756052e73fd3b2eb09fee74ef5dd1.jpg

Edited by Vero
Edited to change title from all capitals, and removed colour/size formatting from text

Share this post


Link to post

@PAUL R FONTENOT Please do not post titles all in capitals, or with wildly unnecessary colourful text. Plain black text and non-capitalised titles makes it far easier to read, and more pleasant for fellow users. 

 

With regards to your workflow query, this is not an issue with Alfred, but will be an issue with your workflow specifically. As instructed by @deanishe previously, if you have an issue with a workflow, please post a link to the workflow itself (you can host it on Dropbox and link to it in your post) so that we can help you further.

 

Quoting from the Reporting Problems with Workflow intro thread:

 

Quote

Your own workflows

 

If you're having a problem with a workflow you're writing, post the actual, non-working workflow. Upload it somewhere (Dropbox?) and post a link.

 

Screenshots and code snippets are not enough. If we can't replicate the problem by running the workflow, we can only guess at what might be wrong. It is unreasonable to expect us to try to recreate your workflow from a code snippet simply in order to help you.

 

Post the broken workflow, so we can run it ourselves. It saves everybody's time.

 

In addition, you should also post:

  1. The version number of:
    1. Alfred
    2. macOS
    3. The version of any non-system language you're using (e.g. nodejs)
    4. The version of any non-system programs you're using (e.g. ffmpeg or youtube-dl) if they aren't bundled in your workflow
  2. Any changes you've made to your macOS environment (e.g. via launchctl setenv) or the language you're using (e.g. via Python's usercustomize.py or sitecustomize.py files)


It might not seem relevant, but if your workflow isn't working and you don't know why, you're likely not in the best position to determine what's relevant and what isn't.

 

So just post the lot. It'll help you get an answer faster.

 

Cheers,
Vero

Share this post


Link to post

@PAUL R FONTENOT I've had a look at your workflow, and it appears you're using two completely independent features relating to Remote, which are 1. The Remote Trigger, and 2. A bundled Remote page.

 

1. You've created a workflow with a Remote Trigger; This one works perfectly when added correctly.

 

To add it, create a new Remote page, or find an empty space in an existing one. Click and choose Workflow Triggers > Remotely launch multiple files > Remote Launch to add that object to your Remote as shown in the screenshot below. This icon will then trigger your workflow, you'll see the Notification Centre notification and hear the sound. I've tested this and it works as expected.

 

 

Screen Shot 2018-07-16 at 16.51.37.png

 

2. Your Remote page

 

The page you've created includes all the individual files, which can be useful if your intention is to launch the individual files sometimes, but will not achieve what you're looking for as far as triggering them all at once.

 

This feature is primarily used when users create pre-defined full pages of triggers (e.g. the Spotify Mini Player's creator provides a full page of workflow triggers). If you have no interest in launching them individually, you can remove the page from your workflow.

 

Cheers,
Vero

Share this post


Link to post

I decided that under real-world conditions, I don't really want to be launching several programs and files at once even if I can.  So, I opted to change my previous workflow up a bit and divide it by application.  I created this new workflow (attached) and I loaded it into the remote page (exactly) according to your instructions above.  I still come up with the same results as before; my workflow launches the files and applications but it does not post notification or play sounds.

 

Don't know what I did that was different than when I loaded the last workflow in according to your instructions with good results.

 

As before, running the latest version of Alfred & the latest version of Mac OS and I have not made any changes to the operating system.

 

I'm stooped!   ?

https://www.dropbox.com/s/hgkff2sdv7sgq6d/LAUNCH 2 OFFICE DOCUMENTS.alfredworkflow?dl=0

Share this post


Link to post

RE:      Launch 2 Office Documents           workflow

 

Out of curiosity, I just added a keyword input to the original workflow in the workflow tab and tried running this workflow from there;  the workflow works fine from the workflow tab, but not from the remote page.  :wacko:

Share this post


Link to post

RE:  Launch 2 Office Documents  workflow

 

(time now is 11:56 Monday) I can't explain it; my workflow is working flawlessly now.  It was not working this afternoon;   I just kept trying and it started working.  ?

Share this post


Link to post

Good afternoon Vero,

 

The attached link is my latest rendition of   "Launch 2 Office Documents"   workflow now going under the name of     APPLICATIONS.alfredworkflow

 

This latest one is working just fine, except for one thing; when I trigger one of the workflows within it, my iMac gives me this error sound; the workflow goes about
it's business and opens the applications & files, gives notification, plays the sound, and posts large type across the screen but every time I trigger the workflow, I get this noise that I normally get when pressing a key that the Mac doesn't like.  Maybe you could run the workflow and see if your Mac gives you the same sound when you trigger it?

 

https://www.dropbox.com/s/0llny72f3wv2qz6/APPLICATIONS.alfredworkflow?dl=0

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...