Jump to content

Alfred Server, Dispatch Key Combos Not Registering


wwvuillemot
 Share

Recommended Posts

I'm trying to use the Alfred Remote feature to use my iPhone as a "puck" for controlling my digital flow using Affinity Photo, Adobe Photoshop, et cetera.  If I can get this to work, I can save a few hundred dollars.

 

That said, I went to add some controls to "Dispatch Key Combo".  When I try to hit CMD+ for "zoom in" for use while using Affinity Photo, the key combo is not recorded.  It just registers the CMD key.  It will register keys like arrow keys, delete, tab, but not any alphanumeric key.  


Bug?  Feature?

 

macOS Mojave (10.14(18A389))

Alfred v3.7 [938]

Alfred 3 does have security approval to control this Mac, too.
Using the Apple keyboard on the laptop

 

REF: https://www.alfredapp.com/help/remote/dispatch-key-combo/  Per the docs it appears that this should work, so I'm assuming a bug ATM.

Edited by wwvuillemot
Add reference URL
Link to comment
Share on other sites

Note, I tried this on my other machine running macOS High Sierra (10.13.6) so this appears to be specific to Mojave.

 

If I look at the console, the closest thing I can get to correlated to my combo dispatch is:

 

27366555: RECEIVED OUT-OF-SEQUENCE NOTIFICATION: 0 vs 417, 513, <private>

 

27366555 remains constant in the log messages

0 vs 4## grows over time.  

513 remains constant in the log messages.

Edited by wwvuillemot
Link to comment
Share on other sites

  • 2 weeks later...

I just updated my other machine to Mojave, and no issues.

 

The only thing I can think of, at the moment, is that the laptop (with issues) has Wacom drivers installed.  If I have time/energy, I will see about uninstalling them to see if that remedies it.

 

FWIW, I have CKB installed on the desktop Mac -- CKB is an extension for using Corsair keyboards – which I have found can cause issues, along with a wired Logitech mouse attached.  But that machine shows no issues.  The otherwise stock reMBP laptop is the one with the issues.  Very weird.

Link to comment
Share on other sites

Resolved.  Not Wacom drivers.  Both my systems are in Japanese.  However, on the desktop I have the US keyboard activated.  On the laptop, only the Japanese keyboard is activated.  I just use the "romaji" option when typing in English.  Once I activated the US keyboard, and selected it, Alfred was okay.

 

So still a bug, but the workaround is to use the US keyboard.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...