Jump to content

[SOLVED] Contacts not showing in Alfred

Recommended Posts

Hi smart people,


When I search and find contact in Alfred (v3.7), it launches Contacts instead of showing it in Alfred like it used to. I'm running 10.14.1 (Mojave), and have Accessibility, Contacts and Full Disk Access checked/allowed in Privacy under Security & Privacy. Within Alfred, "Open Contacts in Alfred" is checked under Contacts and Default Results.


Any help in resolving this will be appreciated! Thanks!

Link to comment

@BigTrees First, launch Alfred's Preferences to Features > Contacts > Advanced and ensure "Use Spotlight metadata for searching contacts" is not checked. 

By default, Alfred uses Apple's Contacts API for searching contacts, and these open in Alfred's Contacts Viewer.


However, if you've checked the Spotlight metadata alternative (under Features > Contacts > Advanced), the results will include all sorts of contacts files (e.g. from old backups, or your Downloads folder) which will always be opened in the Contacts app. :)



Link to comment



Good afternoon (your time), you bloody genius! Unchecking "Use Spotlight metadata for searching contacts" has resolved the issue. Curiously, do you have any idea why showing Contacts in Alfred has worked all these years that I've been using it, and why it would suddenly stop? Previous to today, I'd never touched the "Use Spotlight metadata for searching contacts" box.



Link to comment
  • vitor changed the title to [SOLVED] Contacts not showing in Alfred

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...