Jump to content
Rebecca

Snippets stopped working in Mojave

Recommended Posts

I upgraded to Mojave last week and upgraded Alfred to the latest version right after that.  Today, my snippets suddenly stopped working.  I noticed that Alfred is not on the Automation section of the Security & Privacy settings, and I can't add it.  I tried dragging it from Finder and it just bounces back, and there's no option to add anything.  Please help!  I need my snippets for work.

Share this post


Link to post

Thank you for your help.  At one point, just for a few moments, Alfred said that something was preventing text expansion by locking secure entry.  I think it was MacOS or System or something like that, definitely not an application.

 

I have also noticed that now my Alfred hotkeys are not working either.  I restarted my computer but the issue is persisting.  What else can I do to try to fix this?

Share this post


Link to post

I'm having the same problem. At some point today, all snippets have stopped working for me, persisting through restart. Nothing has been updated recently, and I am on the most recent version of Mojave.

 

Edit: after some more testing, it seems like they suddenly work in some text fields, but not others. For instance, I have an snippet for my company's download page. It works fine in Chrome's address bar, but not in a text field in Help Scout (which is running inside of Chrome). It also doesn't work in Slack's text field (again, running inside of a Chrome tab).

Edited by TheJesusFish

Share this post


Link to post

You're right - I can get a snippet in Chrome's address bar, but not anywhere else in Chrome (like Gmail or Google Sheets).  I also just tried deleting and reinstalling Alfred, and that didn't work either.

Share this post


Link to post

@TheJesusFish @Rebecca If you could update to the latest Alfred 3.8 b958 pre-release from Alfred's update preferences and let me know how you get on. In the latest version of Google Chrome, when Alfred used the Apple Accessibility API to get information about the currently active text field, Chrome was returning different / random process identifiers for each keystroke.

 

I've made a tweak which should work around this apparent Chrome bug.

 

Cheers,

Andrew

Share this post


Link to post
13 minutes ago, Andrew said:

@TheJesusFish @Rebecca If you could update to the latest Alfred 3.8 b958 pre-release from Alfred's update preferences and let me know how you get on. In the latest version of Google Chrome, when Alfred used the Apple Accessibility API to get information about the currently active text field, Chrome was returning different / random process identifiers for each keystroke.

 

I've made a tweak which should work around this apparent Chrome bug.

 

Cheers,

Andrew

That seems to have fixed it! Great work as always, friends :)

Share this post


Link to post
Posted (edited)

Hello, I'm having the same problem- in Catalina, Alfred 4 snippets don't work at all. I have both full disk and accessibility turned on.

 

 

Edited by mspCCMA

Share this post


Link to post
On 1/30/2019 at 5:38 PM, Rebecca said:

Yes, this fixed it for me too!  Thank you!

 

Rebecca, how did you access an older version of Alfred in order to fix this?

Share this post


Link to post

@mspCCMA There's no need to revert to an older version, as snippets should work perfectly in Catalina.

 

If you've upgraded to Catalina, you may need to remove and re-add Alfred to the permissions, as some users experienced permissions corruption in the OS upgrade. 

 

Just remove Alfred from accessibility and full disk access, then re-add (via Alfred's General preferences tab, or manually), and you should be all sorted.

 

If the issue persists, please let me know and I'll help you further :)

 

Cheers,
Vero

Share this post


Link to post

@mspCCMA  Could you please provide more details, so that I can help you further?

 

- Which version of Alfred and macOS are you using?
- Are snippets enabled in Alfred's preferences?
- Is the specific snippet enabled for expansion?
- When you try to expand a snippet, at what stage does it fail? E.g. Does the snippet disappear and partially pasted, or is nothing pasted at all? Do you hear an error beep?
- Does the issue occur in all apps or only some apps? Test in TextEdit, which is one of the simplest apps, as some more complex apps or browsers have their own clipboard management or behaviours that may cause issues
- Do you use any third-party clipboard managers or snippets tools that may be interfering?
 

The more details you provide, the quicker I can help you troubleshoot what's happening :)

 

Cheers,
Vero

Share this post


Link to post

Hi Vero, 

 

In response: 

 

 - Which version of Alfred and macOS are you using? 4.0.7
- Are snippets enabled in Alfred's preferences? Yes, as far as I can see
- Is the specific snippet enabled for expansion? What do you mean by this?
- When you try to expand a snippet, at what stage does it fail? E.g. Does the snippet disappear and partially pasted, or is nothing pasted at all? Do you hear an error beep? No sounds are made and no snippet appears.
- Does the issue occur in all apps or only some apps? Test in TextEdit, which is one of the simplest apps, as some more complex apps or browsers have their own clipboard management or behaviours that may cause issues All apps.
- Do you use any third-party clipboard managers or snippets tools that may be interfering? No; I used to run TextExpander but have uninstalled it.

 

Thanks for your help!

 

 

Share this post


Link to post

@mspCCMA Could you create a Diagnostics file from Alfred's Help preferences and email that to our info@ address so I can take a look to see if snippet expansion is correctly configured in Alfred on your Mac :) 

Share this post


Link to post

Since Googling "alfred snippets stopped working" leads here, I'll post here my 2 cents

 

If you are using Keyboard Maestro, try quitting it and check if it solves the Alfred snippets expansion problem.

If it does, then you "just" need to find which Macro breaks it and adjust it.

(For me, it was a macro hijacking cmd+v in specific app)

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...