Jump to content

Terminal integration stopped working with the latest update

Recommended Posts

Hey all!  Alfred 3.8, MacOS 10.14- the Alfred 3.8 update has killed my terminal integration.  Whenever I >cmd my terminal no longer loads.  I have verified that all the accessibility/security/automation settings are configured for Alfred, and I'm not sure how to troubleshoot this issue.  Can you provide any guidance?  

Share this post

Link to post

@onewheelskyward are you on the general release of 3.8 (build 959)? If not, update to this and things should work.


If still not working, and if Finder and Terminal are selected in the Automation settings, then try restarting your Mac. In one of the 3.8 pre-releases, I had updated to Xcode 10 without adding the required NSAppleEventsUsageDescription for automation, so if you updated through that pre-release, it may have confused your Mac.




Share this post

Link to post

Ok updating here- a reboot indeed solved it.  Then I sold that machine to a friend.  I had the same issue on another mac, this time on 10.12.something, and a reboot solved that too.  Neither of them were on the pre-release schedule, so it was probably an xcode update that borked it.  In any event, turning it off and back on seems to be the solution.   thanks again!  :) 



Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...