Jump to content
mikejandreau

[SOLVED] Update not sticking, keeps forcing me to update to 3.8 again and again.

Recommended Posts

For the last few days, my main desktop won't seem to stay upgraded to 3.8.

 

I get the alert there's an update, download it, run it, password input, then a second or two later it seems to want me to upgrade again.

 

I grabbed a video of it happening, which you can see here: https://take.ms/YZn66 I've done this maybe 20 times in the last few days.

 

My other two machines upgraded fine, so I'm sure it's something specific to this machine, I just don't know what to look for.

Share this post


Link to post

Instead of upgrading through the built-in updater, have you tried downloading Alfred from the website and overwriting your current install?

Share this post


Link to post

That seems to have worked.

 

The version in /Applications showed as damaged when I tried to overwrite it, which could explain why the update wasn't working.

 

Once I deleted it and copied it over from the .dmg, all appears well again. Thanks Vitor!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×