Jump to content
MRMJP

Pasting Snippets To Save As... Dialogues

Recommended Posts

Holy F@ck.

 

I can't believe I didn't know about this app sooner. I think it's going to replace a few different apps for me and do it all in one. However, one big dealbreaker is that I can't seem to get my Snippets to paste when I am in a Save As... or File Save dialogue box of an app.

With some apps, nothing happens. With another app, a lowercase v appears. With another app, the snippet pastes but so does part of my prefix. Am I doing something wrong or is there an easy way to allow for snippets to be pasted in Save and Save As... dialogue boxes?

 

I rely on Snippets a lot when saving/naming new files in various audio apps.


Thanks,

Justin

Edited by MRMJP

Share this post


Link to post

I see that this seems to work OK with official Apple apps actually, it's just 3rd party apps where the behavior is strange.

 

Can anything be done on my end (or maybe an update to Alfred) to get around this?

Share this post


Link to post
3 hours ago, vitor said:

Welcome @MRMJP,

 

Check the troubleshooting steps. Closer to the end you’ll find a case that seems like what you’re experiencing.

 

Thanks. Somehow I missed that setting when I was digging around. Putting it at the slowest setting solved one of my app problems but anything faster than the slowest setting didn't work. Does this mean that app is too responsive or too slow?

One of my apps just won't accept snippets at all regardless of speed. Later today I'll have to try the app that was working OK and make sure it's still working OK.

 

 

Share this post


Link to post

It might help if you describe which apps have which problems. There should be a pattern (Electron apps or apps built in Java, for example)

Share this post


Link to post

Thanks. The app that won't accept a snippet at all is iZotope RX 7 file Save/Save As... menu.

 

The app that I had to set the speed to slowest setting is REAPER.

 

That app that seemed OK right away is WaveLab Pro 9.5. It was also OK with the slowest setting but I haven't checked all menus/places in the app yet.

 

Outside of the native Apple apps, those are the ones I use most.

 

I still need to check Weiss Saracon which still works in Mojave but has not been updated in some time so I'm guessing the framework is old if that helps.

 

Edited by MRMJP

Share this post


Link to post
22 hours ago, MRMJP said:

Outside of the native Apple apps

 

Snippet expansion is a crapshoot with non-native applications. There's not a whole lot Alfred can do when it comes to apps that aren't properly integrated with macOS.

 

In my experience, you often end up with non-native app A, which works fine with Alfred's snippets, but not with (say) Typinator snippets, and non-native app B, which works with Typinator's snippets, but not Alfred's.

 

The issues really need to be solved by the developers of the poorly-integrated apps.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...