Jump to content

Alfred window should pop up in the active screen for multi screen environment


Recommended Posts

For multi-screen environment, Alfred window always pop up in the original screen. It sometimes bring inconvenience to turn my head from one screen to another. When starting an application, the application window show up in the active screen, so I think it is implementable to detect which screen is active.

Link to post
Share on other sites
  • 11 months later...

Hopefully this thread isn't so old as to be "Necro-posting", but I thought the context was useful and it isn't like you need yet another identical thread title!

 

I really want Alfred to open on the active screen, but the setting has never had an effect for me.  If I chose the "mouse screen" it works as expected, but I use keyboard navigation a lot so frequently the mouse is not in the screen I'm actually using. For me this has been persistent since my first use of Alfred more than 1.5 years ago.  So that is through Mojave and now Catalina.  I finally went looking for a solution, and have been surprised at all the people here talking about it working as expected. 

 

Are there any clues on what I could do in order to get it working as expected?

 

Alfred 4.0.8

macOS 10.15.2

Link to post
Share on other sites
  • 2 months later...

I have the same issue @troycurtisjr and many others have. 

 

1. The active screen option doesn't work. 

2. The mouse option is only good if you switch applications with the mouse (many users don't). 

 

It's a little annoying to move your head to your primary Alfred screen every time you want to summon it. There should be a setting to always make it appear on the screen with the focused app. 

Link to post
Share on other sites

@jeremy What apps are you using when you're seeing this? Could you please test with TextEdit on one screen and Safari on the other, as these are native basic apps?

 

The Active Screen option works as expected, and I've just tested it on various OS versions from El Capitan up to Mojave. I'm curious whether you might be using an app that doesn't take active focus (e.g. the name of the app doesn't appear at the top right of the menu bar) and therefore macOS isn't treating it as the actively focused screen in the same way.

 

Let me know how you get on.

 

Cheers,
Vero

Link to post
Share on other sites

I just confirmed using TextEdit and Finder. I put Finder on the primary screen (the one with dock and menubar), and TextEdit on a secondary screen. I clicked on TextEdit, and confirmed it had focus (typing resulted in text entered into the document). Then I activated summoned Alfred and it opened on the primary screen.

 

Perhaps it is related to the fact that I have the "Displays have separate Spaces" disabled? I believe the default is that they do have separate spaces.  I know that I would also like a menu bar on all desktops, but I can't have both the menu bar everywhere and a shared space between the displays. So perhaps there is a similar issue with Alfred being able to detect the current active screen?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...