Jump to content

Alfred slow to open on Mojave


Recommended Posts

I checked back through the forums and didn't see anyone talking about this, but Alfred is opening really slowly for me ever since upgrading to Mojave.  It feels like a 1 to 2 second delay before it appears.  This means that very often I'm accidentally typing my search into whatever application I was in before Alfred is available.  Alfred used to be instant like Spotlight, and Spotlight still is instant, but Alfred is not.

 

Any ideas?  Is this Apple's doing?  One or two seconds may not seem like a lot, but it's at least ten times slower than it used to be, which means all my muscle memory (from 8-9 years of use) is messing with me.

Link to post

@Joshua Nichols There are a few things that could be at play here, as Alfred should be as fast as ever.

  • Did you just upgrade to or install Mojave? Is the CPU high while macOS does its first index? If so, that could be slowing your Mac down generally
  • What's your hotkey? If you're trying to use Cmd + Space and also have the "Hold Cmd for Siri", it's likely slowing things down while macOS waits to work out if you want to call up Siri or not. Disable that feature if you're not using it. More details here: https://www.alfredapp.com/help/troubleshooting/cmd-space/#dont-show

Those are the two most obvious things to check out. 

 

Cheers,
Vero

Link to post
  • 7 months later...

I'm still having this issue, and have been for I think six months or so. Siri hotkey is not set to the same as my Alfred hotkey.

 

It sometimes takes about a full second for the Alfred input window to show up, and I often find myself typing my Alfred query into whatever text field I was previously in. Sometimes I hit the Alfred hotkey again because it's not showing up, which causes it to close as soon as it does appear.

 

Any other reason it might be taking a second to open? I remember it used to be lightning quick.

Link to post

@Jay S you could try temporarily creating a new user profile on your Mac, switching to that user and seeing if there is delay there. It may be something conflicting on your main profile.

 

One other thing to try is reindexing your macOS metadata (shortcut for this in Alfred's Advanced prefs).

Link to post
  • 2 months later...

@Andrew

I'm on Mojave (since the day I got this MBP), and Siri is just disabled.

Alfred used to be responsive, but now it takes about 3 seconds to load when I press my hot key for Alfred after not using it for like more than several minutes.

Could it be the issue that Alfred is being swapped out because there is a small amount of free memory?

Or could it be that there are too many files on my MBP?

 

Link to post

My experience in Mojave is that the macOS program iconservisesagent is going nuts. On my system, it was caused by the Path Finder program and some extensions added to Finder (Dropbox, Deskdrawer, etc). Removing Finder extensions and stop using Path Finder fixed all my issues with Alfred being slow.

 

I’ve notifed the authors of Path Finder, but they have not replied.

Link to post
  • 4 months later...

I have the same issue. When I use my assigned shortcut (cmd+space) it takes 1-2 seconds for Alfred to show up. The same is true for the clipboard history (cmd+'). I've tried all the things mentioned in this post

 

• Disabled Siri

• Tried another hotkey

• Reindexed the os metadata (and rebooted)

• No finder extensions installed.

• Quit all non-essential apps

 

Once it Alfred has loaded the first time it's spiffy and alert again, until I either jumped around a bit between apps or do something else for few minutes.

 

Do you have any other ideas on what to try? It's really annoying to not be able to trust Alfred to show up as expected :(

 

Edit: I'm on Catalina 10.15.3, with a MBP 2016 Touchbar. 8 GB ram, 2.9 GHz dual-core I5

 

Edited by hampus
Added system specs
Link to post
  • 2 months later...
On 5/5/2020 at 10:05 AM, hampus said:

I have the same issue. When I use my assigned shortcut (cmd+space) it takes 1-2 seconds for Alfred to show up. The same is true for the clipboard history (cmd+'). I've tried all the things mentioned in this post

 

• Disabled Siri

...

 

 

I just found this thread as I was tired of the delay too. I have always had Siri disabled, but despite that I think it still had the hotkey reserved. What fixed the delay for me was actually re-enabling Siri, setting to a new hotkey I'll never use, then disabling it again. It's a silly solution, but hopefully it can help someone else!

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...