Jump to content
cassiano

Notification "freezes" browser after using text based workflow

Recommended Posts

Hello, all;

 

Alfred is currently doing a weird  bug. When I need to use a text-based workflow (like Lorem Ipsum generator or Strip Clipboard Text Formating), when the notification message comes up  (like the Lorem Ipsum on in the screenshot) it "freezes" the browsers and I can only paste the text if I alt-tab between windows and click with the cursor somewhere else and then come back:

 

XNYfPvS.png

 

yR42u4K.png

 

It's still possible to use the app, but not when it's needed to use it often

 

Alfred 3.8.1
Build 961, Wednesday 13th March 2019


Mac OSX Mojave 10.14.3

 

Thanks

Share this post


Link to post
29 minutes ago, cassiano said:

it "freezes" the browsers

 

You mean Firefox? Does the same thing happen with other applications?

Share this post


Link to post

Both Firefox and Chrome. After I run a workflow by opening a dialog box (like the one here), when I come back to the browser, it does not accept any typing unless I switch application windows (like browser and mail client, for example) with alt-tab shortcut. Once I switch to another window and come back, it starts typing normally 

Share this post


Link to post
1 hour ago, cassiano said:

After I run a workflow by opening a dialog box (like the one here)

 

I don't see a dialog box. Do you mean Alfred's window?

 

Could you check the help page on using Alfred with Mojave and make sure you have given Alfred all the permissions it needs.

 

If that doesn't work, can you provide a link to a workflow that is having the issue? It is not clear which workflows you are talking about.

Share this post


Link to post

@cassiano As well as looking at what @deanishe is suggesting and providing the workflow you're having issues with, could you please try your workflow with a plain text TextEdit file as your pasting destination?

 

The objective is to simplify down to the basics; Test using the most native apps possible, e.g. TextEdit, Safari.

 

Cheers,
Vero

Share this post


Link to post

OK.

 

I use Alfred to open most my apps and to write a lot - shortening URLs, opening apps, checking words on a dictionary, copying and pasting text, etc.

 

What I noticed is that when I open the Alfred dialog window and type a command (like "Define" to see the dictionary description), even if I don't click enter to open the targeted app (in this case, "Dictionary"), when I come back to the application I was using before (usually a browser where I am writing), if I try to type or paste something, it does nothing and rings the "error" sound. I need then to Alt-Tab to go to other app and then Alt-Tab again to come back to the browser so it "responds" allowing me to type or paste text .

 

The behaviours is the same to any app opened by Alfred while writing on the browser (usually Google Docs or Spreadsheet, but in some cases the URL field of the browser itself).

 

Is that detailed enough? 🙂

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...