Jump to content

Problem with font aliasing on Alfred 4, started in 3.8 [Workaround Available]


Recommended Posts

1428134694_CleanShot2019-05-29at23_32_25.png.b397da03a4f0a3a2173c75885b9261f5.png

 

Hi,

 

As you can see in the screenshot, I'm having the problem with font rendering on Mojave starting with Alfred 3.8 version. Everything was ok until Alfred 3.8. I just updated to Alfred 4 and bought my powerpack upgrade thinking that this would be fixed, but I was wrong.

 

Can you please take a look at this? I can't be going back to 3.7 now. If it means anything, it displays almost normal on Macbook display, but on my 34" 3440x1440 it's awful.

 

Thanks!

Link to post

@sysninja This is a really awkward issue and a bug I've raised with Apple regarding font rendering in Mojave on transparent panels, and only seems to affect some configurations of Mac.

 

It was broken in 3.7 and before (fonts rendering too light).

 

Could you try a different theme, or different fonts? I may add a hidden default writes which will restore the smoothed front, but incorrectly weighted behaviour for people who see this issue, and I'm going to bump the bug report.

Link to post

Hey @Andrew thanks for the fast reply.

 

I've tried all the themes and a couple of fonts and it's the same. I actually stayed on the last version of 3.7.x because I had no problems on it.

 

Thanks for this, Apple really screwed the font rendering in Mojave.

Edited by sysninja
Link to post

@Andrew Thanks for getting back to me.

 

No - I do not have any accessibility options enabled that would impact Alfred.

 

After posting this question, I noticed that the black border around Alfred only shows up when Mojave is in Dark mode (previous screenshot above). When in Light mode, there's still a small border around the window, however, it's very light gray and hardly visible with Alfred's drop shadow (see screenshot below).

1909026892_ScreenShot2019-05-30at2_01_33PM.jpg.bf0c8b18fa55ab5d46aacb356ca09bb7.jpg

 

Unfortunately, I don't have time to create a new user account at the moment, but I'll give it a try this evening when I leave the office. 

 

Thanks again for all of your help!

 

@sysninja I'm not sure if it's helpful, but I used to notice a difference with the font weighting issue sometimes when I would toggle the "Use font smoothing when available" option in System Preferences off and on (System Preferences → General).

Edited by Jasondm007
Link to post

Sorry for double post.

 

I've created sort of a workaround for Alfred.

 

Quit Alfred, go to the Terminal and type:

 

defaults write -app Alfred\ 4 CGFontRenderingFontSmoothingDisabled -bool YES

Start Alfred again and it will look as good as it always looked. I have my CGFontRenderingFontSmoothingDisabled to NO globally in the system as Mojave doesn't render fonts correctly on non-Retina monitors.

Edited by sysninja
Link to post

@sysninja Thanks for the suggestion! I really appreciate it.

 

Just for clarification, are you recommending:

  1. to "Use font smoothing when available" from System Preferences,
  2. to run the app-specific terminal command (defaults write -app  Alfred\ 4 CGFontRenderingFontSmoothingDisabled  -bool YES), but
  3. to leave the global terminal command alone (defaults write -g CGFontRenderingFontSmoothingDisabled -bool NO)?

Thanks for your help!

Link to post
  • Andrew changed the title to Problem with font aliasing on Alfred 4, started in 3.8 [Workaround Available]

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...