Jump to content

Recommended Posts

Posted (edited)

Alfred version: 4.0.1 b1078

MacOs version: 10.14.5

Prefs(~/Library/Application Support/Alfred/prefs.json):

{
  "syncfolders" : {
    "4" : "~/Dropbox/Alfred"
  },
  "current" : "/Users/BorisM/Dropbox/Alfred/Alfred.alfredpreferences"
}

 

I migrated from version 3 to 4, I made the respective backup of my preferences before and all works well - all my preferences were migrated, however every time I made a change on my preferences works until I reboot the computer or I restart Alfred.

 

I don't know if this should be part of the migration of the preferences, but the Alfred shortcut, the default Appearance Theme, enable the 1Password feature, the clipboard hotkey, etc are shown with the default value, so when I change its value, this one is not kept, like I said before.

Edited by Boris
grammar

Share this post


Link to post
Share on other sites

Is the sync folder your preferences are in available on boot? Do you have Dropbox running normally, or are you using selective sync?

 

It sounds like Alfred might be starting before its preferences are available, which would cause it to use default values instead.

Share this post


Link to post
Share on other sites

My Dropbox is available at boot, however, even if it wasn't like that, that file is available when Dropbox is not running.

 

I have a selective sync on Dropbox, how that could affect the preferences file?


I don't think that Alfred might be starting before its preferences are available because even when I force Alfred to quit and I start it again those preferences disappear.

Share this post


Link to post
Share on other sites

I'm experiencing the same issue. It's definitely something with Dropbox as things work when I changed the sync location.

Share this post


Link to post
Share on other sites
On 6/7/2019 at 10:22 PM, Boris said:

I have a selective sync on Dropbox, how that could affect the preferences file?

 

I got selective sync mixed up with smart sync.

 

Smart sync does not work properly with Alfred.

Share this post


Link to post
Share on other sites
Posted (edited)

I tried changing the location out of Dropbox and restarting Alfred, but the problem persists 🙁

Edited by Boris
grammar

Share this post


Link to post
Share on other sites

@Boris Could you try backing up your Alfred.alfredpreferences (to be safe), then quitting Alfred 4, deleting the prefs.json file and the Alfred.alfredpreferences in the same folder. Then restart Alfred 4 and skip any offered migration to get a completely clean set of preferences.

 

Are preferences saving in this scenario?

Share this post


Link to post
Share on other sites

@Andrew I did what you told me and Alfred is working normally. Besides, I'm using a folder in dropbox again, I moved the workflows and snippets of the other Alfred.alfredpreferences, and it is saving my preferences without any problem. 🤷🏽‍♂️

Share this post


Link to post
Share on other sites

×
×
  • Create New...