Jump to content
Kaisersoze

Alfred 4 went something wrong with macOS 10.15

Recommended Posts

I have updated to macOS 10.15 Catalina.

But I met the problem like this...

I couldn't see the each icon for Calculator, Dictionary, and Contact..

 

How can I fix it? 

 

Thanks in advance.

스크린샷 2019-06-10 오후 2.31.44.png

Share this post


Link to post

Welcome @Kaisersoze,

 

There’s nothing you can do to fix it, unless reverting back to Mojave. Catalina is a beta OS and should not be used lightly. This will be either fixed on Apple’s side or Alfred’s side.

 

@Andrew Seems like the problematic icons are the ones that map to system apps, so it’s bound to be connected to the file system hierarchy restructuring. However, they did say in the WWDC talk that this is not supposed to be noticed, and they use the new firmlinks to make the connection to old locations. They also said that on the first beta the read-only file system is still read-write and that will change in a future build, so this may also not be finalised yet. This might be worth not looking into so soon.

Share this post


Link to post

I haven't installed Catalina yet (I also generally recommend against anybody installing a beta OS this early if it's their main Mac), but I have made a few tweaks for the next 4.0.2 build which should get these icons back again. I'll likely out this build tomorrow.

 

Cheers,

Andrew

Share this post


Link to post
Posted (edited)
12 hours ago, vitor said:

Welcome @Kaisersoze,

 

There’s nothing you can do to fix it, unless reverting back to Mojave. Catalina is a beta OS and should not be used lightly. This will be either fixed on Apple’s side or Alfred’s side.

 

@Andrew Seems like the problematic icons are the ones that map to system apps, so it’s bound to be connected to the file system hierarchy restructuring. However, they did say in the WWDC talk that this is not supposed to be noticed, and they use the new firmlinks to make the connection to old locations. They also said that on the first beta the read-only file system is still read-write and that will change in a future build, so this may also not be finalised yet. This might be worth not looking into so soon.

 

Thank you for the replies. :)

Edited by Kaisersoze

Share this post


Link to post

If you update to Alfred's latest 4.0.2 pre-release b1086, could you let me know if those icons are still missing?

 

Thanks,

Andrew

Share this post


Link to post

Everything seems to be there now, except for "iTunes", but that is to be expected. 🤓 Incidentally, I had been running 4.0.1 and few, if any, applications were showing up when searching in Alfred, so I'm glad to see things seem to be back to normal on 4.0.2. (Not having any apps show up made me realise just how much I use Alfred/dislike Spotlight... 😉 Thanks a lot, Andrew.)

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...